Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem building OpenMPI with PGI compilers
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-12-09 16:36:51


That's the commit message for r22273. Also see the commit message for r22274 (https://svn.open-mpi.org/trac/ompi/changeset/22274).

Meaning: the fix is now in the SVN trunk; it hasn't migrated over to the v1.4 and v1.5 branches yet. It's an autogen.sh fix -- you should be able to download autogen.sh from our SVN trunk and run it on your 1.4 tree.

On Dec 9, 2009, at 4:23 PM, David Turner wrote:

> Hi all,
>
> My first ever attempt to build OpenMPI. Platform is Sun Sunfire x4600
> M2 servers, running Scientific Linux version 5.3. Trying to build
> OpenMPI 1.4 (as of today; same problems yesterday with 1.3.4).
> Trying to use PGI version 10.0.
>
> As a first attempt, I set CC, CXX, F77, and FC, then did "configure"
> and "make". Make ends with:
>
> libtool: link: pgCC --prelink_objects --instantiation_dir Template.dir
> .libs/mpicxx.o .libs/intercepts.o .libs/comm.o .libs/datatype.o
> .libs/win.o .libs/file.o -Wl,--rpath
> -Wl,/project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/ompi/.libs
> -Wl,--rpath
> -Wl,/project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/orte/.libs
> -Wl,--rpath
> -Wl,/project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/opal/.libs
> -Wl,--rpath -Wl,/global/common/tesla/usg/openmpi/1.4/lib
> -L/project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/orte/.libs
> -L/project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/opal/.libs
> ../../../ompi/.libs/libmpi.so
> /project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/orte/.libs/libopen-rte.so
> /project/projectdirs/mpccc/usg/software/tnt/openmpi/openmpi-1.4/opal/.libs/libopen-pal.so
> -ldl -lnsl -lutil -lpthread
> pgCC-Error-Unknown switch: --instantiation_dir
> make[2]: *** [libmpi_cxx.la] Error 1
>
> So I Googled "instantiation_dir openmpi", which led me to:
>
> http://cia.vc/stats/project/OMPI?s_message=3
>
> where I see:
>
> There's still something wrong with the C++ support, however; I get
> errors about a template directory switch when compiling the C++ MPI
> bindings (doesn't happen with PGI 9.0). Still working on this... it
> feels like it's still a Libtool issue because OMPI is not putting in
> this compiler flag as far as I can tell:
>
> {{{
> /bin/sh ../../../libtool --tag=CXX --mode=link pgCC -g -version-info
> 0:0:0 -export-dynamic -o libmpi_cxx.la -rpath /home/jsquyres/bogus/lib
> mpicxx.lo intercepts.lo comm.lo datatype.lo win.lo file.lo
> ../../../ompi/libmpi.la -lnsl -lutil -lpthread
> libtool: link: tpldir=Template.dir
> libtool: link: rm -rf Template.dir
> libtool: link: pgCC --prelink_objects --instantiation_dir Template.dir
> .libs/mpicxx.o .libs/intercepts.o .libs/comm.o .libs/datatype.o
> .libs/win.o .libs/file.o -Wl,--rpath
> -Wl,/users/jsquyres/svn/ompi-1.3/ompi/.libs -Wl,--rpath
> -Wl,/users/jsquyres/svn/ompi-1.3/orte/.libs -Wl,--rpath
> -Wl,/users/jsquyres/svn/ompi-1.3/opal/.libs -Wl,--rpath
> -Wl,/home/jsquyres/bogus/lib -L/users/jsquyres/svn/ompi-1.3/orte/.libs
> -L/users/jsquyres/svn/ompi-1.3/opal/.libs ../../../ompi/.libs/libmpi.so
> /users/jsquyres/svn/ompi-1.3/orte/.libs/libopen-rte.so
> /users/jsquyres/svn/ompi-1.3/opal/.libs/libopen-pal.so -ldl -lnsl -lutil
> -lpthread
> pgCC-Error-Unknown switch: --instantiation_dir
> make: *** [libmpi_cxx.la] Error 1
> }}}
>
> I noticed the comment "doesn't happen with PGI 9.0", so I re-did the
> entire process with PGI 9.0 instead of 10.0, but I get the same error!
>
> Any suggestions? Let me know if I should provide full copies of the
> configure and make output. Thanks!
>
> --
> Best regards,
>
> David Turner
> User Services Group email: dpturner_at_[hidden]
> NERSC Division phone: (510) 486-4027
> Lawrence Berkeley Lab fax: (510) 486-4316
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Jeff Squyres
jsquyres_at_[hidden]