Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with mpirun -preload-binary option
From: Josh Hursey (jjhursey_at_[hidden])
Date: 2009-12-09 13:15:20


I verified that the preload functionality works on the trunk. It seems
to be broken on the v1.3/v1.4 branches. The version of this code has
changed significantly between the v1.3/v1.4 and the trunk/v1.5
versions. I filed a bug about this so it does not get lost:
   https://svn.open-mpi.org/trac/ompi/ticket/2139

Can you try this again with either the trunk or v1.5 to see if that
helps with the preloading?

However you need to fix the password-less login issue before anything
else will work. If mpirun is prompting you for a password, then it
will work properly.

-- Josh

On Nov 12, 2009, at 3:50 PM, Qing Pang wrote:

> Now that I have passwordless-ssh set up both directions, and
> verified working - I still have the same problem.
> I'm able to run ssh/scp on both master and client nodes - (at this
> point, they are pretty much the same), without being asked for
> password. And mpirun works fine if I have the executable put in the
> same directory on both nodes.
>
> But when I tried the preload-binary option, I still have the same
> problem - it asked me for the password of the node running mpirun,
> and then tells that scp failed.
>
> ---------------------------------------------------------------------------------------------------------------
>
>
> Josh Wrote:
>
> Though the --preload-binary option was created while building the
> checkpoint/restart functionality it does not depend on checkpoint/
> restart function in any way (just a side effect of the initial
> development).
>
> The problem you are seeing is a result of the computing environment
> setup of password-less ssh. The --preload-binary command uses
> 'scp' (at the moment) to copy the files from the node running mpirun
> to the compute nodes. The compute nodes are the ones that call
> 'scp', so you will need to setup password-less ssh in both directions.
>
> -- Josh
>
> On Nov 11, 2009, at 8:38 AM, Ralph Castain wrote:
>
>> I'm no expert on the preload-binary option - but I would suspect that
> is the case given your observations.
>>
>> That option was created to support checkpoint/restart, not for what
> you are attempting to do. Like I said, you -should- be able to use
> it for that purpose, but I expect you may hit a few quirks like this
> along the way.
>>
>> On Nov 11, 2009, at 9:16 AM, Qing Pang wrote:
>>
>> > Thank you very much for your help! I believe I do have password-
>> less
> ssh set up, at least from master node to client node (desktop ->
> laptop in my case). If I type >ssh node1 on my desktop terminal, I
> am able to get to the laptop node without being asked for password.
> And as I mentioned, if I copy the example executable from desktop to
> the laptop node using scp, then I am able to run it from desktop
> using both nodes.
>> > Back to the preload-binary problem - I am asked for the password of
> my master node - the node I am working on - not the remote client
> node. Do you mean that I should set up password-less ssh in both
> direction? Does the client node need to access master node through
> password-less ssh to make the preload-binary option work?
>> >
>> >
>> > Ralph Castain Wrote:
>> >
>> > It -should- work, but you need password-less ssh setup. See our FAQ
>> > for how to do that, if you are unfamiliar with it.
>> >
>> > On Nov 10, 2009, at 2:02 PM, Qing Pang wrote:
>> >
>> > I'm having problem getting the mpirun "preload-binary" option to
>> work.
>> >>
>> >> I'm using ubutu8.10 with openmpi 1.3.3, nodes connected with
> Ethernet cable.
>> >> If I copy the executable to client nodes using scp, then do
>> mpirun,
> everything works.
>> >>
>> >> But I really want to avoid the copying, so I tried the
> -preload-binary option.
>> >>
>> >> When I typed the command on my master node as below (gordon-
>> desktop
> is my master node, and gordon-laptop is the client node):
>> >>
>> >>
> --------------------------------------------------------------------------
>> >> gordon_at_gordon-desktop:~/Desktop/openmpi-1.3.3/examples$ mpirun
>> >> -machinefile machine.linux -np 2 --preload-binary $(pwd)/
>> hello_c.out
>> >>
> --------------------------------------------------------------------------
>> >>
>> >> I got the following:
>> >>
>> >> gordon_at_gordon-desktop's password: (I entered my password here,
> why am I asked for the password? I am working under this account
> anyway)
>> >>
>> >>
>> >> WARNING: Remote peer ([[18118,0],1]) failed to preload a file.
>> >>
>> >> Exit Status: 256
>> >> Local File:
> /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/hello_c.out
>> >> Remote File: /home/gordon/Desktop/openmpi-1.3.3/examples/
>> hello_c.out
>> >> Command:
>> >> scp
> gordon-desktop:/home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
>> >> /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/
>> hello_c.out
>> >>
>> >> Will continue attempting to launch the process(es).
>> >>
> --------------------------------------------------------------------------
>> >>
> --------------------------------------------------------------------------
>> >> mpirun was unable to launch the specified application as it could
> not access
>> >> or execute an executable:
>> >>
>> >> Executable: /home/gordon/Desktop/openmpi-1.3.3/examples/
>> hello_c.out
>> >> Node: node1
>> >>
>> >> while attempting to start process rank 1.
>> >>
> --------------------------------------------------------------------------
>> >>
>> >> Had anyone succeeded with the 'preload-binary' option with the
> similar settings? I assume this mpirun option should work when
> compiling openmpi with default options? Anything I need to set?
>> >>
>> >> --qing
>> >>
>> >>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users