Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_Comm_spawn lots of times
From: Nicolas Bock (nicolasbock_at_[hidden])
Date: 2009-12-01 18:26:59


Linux mujo 2.6.30-gentoo-r5 #1 SMP PREEMPT Thu Sep 17 07:47:12 MDT 2009
x86_64 Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz GenuineIntel GNU/Linux

On Tue, Dec 1, 2009 at 16:24, Ralph Castain <rhc_at_[hidden]> wrote:

> It really does help if we have some idea what OMPI version you are talking
> about, and on what kind of platform.
>
> This issue was fixed to the best of my knowledge (not all the pipes were
> getting closed), but I would have to look and see what release might contain
> the fix...would be nice to know where to start.
>
>
> On Dec 1, 2009, at 4:15 PM, Nicolas Bock wrote:
>
> After reading Anthony's question again, I am not sure now that we are
> having the same problem, but we might. In any case, the attached example
> programs trigger the issue of running out of pipes. I don't see how orted
> could, even if it was reused. There is only a very limited number of
> processes running at any given time. Once slave terminates, how would it
> still have open pipes? Shouldn't the total number of open files, or pipes,
> be very limited in this situation? And yet, after maybe 20 or so iterations
> in master.c, orted complains about running out of pipes.
>
> nick
>
>
> On Tue, Dec 1, 2009 at 16:08, Nicolas Bock <nicolasbock_at_[hidden]> wrote:
>
>> Hello list,
>>
>> a while back in January of this year, a user (Anthony Thevenin) had the
>> problem of running out of open pipes when he tried to use MPI_Comm_spawn a
>> few times. As I the thread his started in the mailing list archives and have
>> just joined the mailing list myself, I unfortunately can't reply to the
>> thread. "The thread was titled: Doing a lot of spawns does not work with
>> ompi 1.3 BUT works with ompi 1.2.7".
>>
>> The discussion stopped without really presenting a solution. Is the issue
>> brought up by Anthony fixed? We are running into the same problem.
>>
>> Thanks, nick
>>
>>
> <master.c><slave.c>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>