Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Elementary question on openMPI application location when using PBS submission
From: Belaid MOA (belaid_moa_at_[hidden])
Date: 2009-12-01 12:57:39


Hello everyone,
 I am new to this list and I have a very elementary question: suppose we have three machines, HN (Head Node hosting the pbs server), WN1 (A worker node) and WN (another worker node). The PBS nodefile has WN1 and WN2 in it (DOES NOT HAVE HN).
My openMPI program (hello) and PBS script(my_script.sh) reside on the HN. When I submit my PBS script using qsub -l nodes=2 my_script.sh, I get the following error:

--------------------------------------------------------------------------
mpirun was unable to launch the specified application as it could not find an executable:

Executable: hello
Node: WN2

while attempting to start process rank 0.
--------------------------------------------------------------------------

How come my hello program is not copied automatically to the worker nodes? This leads to my elementary question:
where the application should be when using a PBS submission?

Note that when I run mpirun from HN with machinefile containing WN1 and WN2, I get the right output.

Any help on this is very appreciated.

~Belaid.

                                               
_________________________________________________________________
Windows Live: Keep your friends up to date with what you do online.
http://go.microsoft.com/?linkid=9691815