Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] configuration settings for Mac OSX
From: Jurgen Heymann (juheymann_at_[hidden])
Date: 2009-12-01 12:20:12

Hi Jeff,

Thank you for your feedback. In all cases, I installed it clean. After consulting the mpiBLAST user group, I learned that there is an issue building mpiBLAST with openMPI on Intel platforms and that it is being investigated. Once I learn more about it, I will post it here. I would still try to get mpiBLAST built on PPC (OS 10.4) using openMPI and I would appreciate any hints regarding settings for running ./configure.



On Nov 23, 2009, at 12:51 PM, Jurgen Heymann wrote:

> I am trying to understand what parameters are essential to include
> when running ./configure with openmpi-1.3.3 when working with Mac
> using PPC (OS 10.4) or Intel platform (OS 10.5). What compilers and
> settings work best for the individual platforms (HFS+) and lead to
> robust installations?
> Fact is that I can build openmpi rather easily using ./configure --
> prefix=path_to_location on any of the mentioned platforms. Test on
> the package-provided examples work without flaw. However, building
> mpiblast-1.6 using openmpi fails on either platform (clean, no mpi
> alternatives present). Error messages indicate that certain
> functions provided within openmpi are not defined e.g.,
> MPI::Datatype::Free() and MPI::WIN::Free().

Sorry for the delay on replying here.

Make sure that you are using the Open MPI that you have installed from
source and not the Open MPI that is installed by OS X by default.

Does that help?

Jeff Squyres