Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Trouble with SGE integration
From: Reuti (reuti_at_[hidden])
Date: 2009-11-30 11:47:44


Hi,

Am 30.11.2009 um 16:33 schrieb Ondrej Glembek:

> we are using a custom starter method in our SGE to launch our
> jobs... It
> looks something like this:
>
> #!/bin/sh
>
> # ... we do whole bunch of stuff here
>
> #start the job in thus shell
> exec "$@"

the "$@" should be replaced by the path to the jobscript (qsub) or
command (qrsh) plus the given options.

For the spread tasks to other nodes I get as argument: " orted -mca
ess env -mca orte_ess_jobid ...". Also no . ./.profile.

So I wonder, where the . ./.profile is coming from. Can you put a
`sleep 60` or alike before the `exec ...` and grep the built line
from `ps -e f` before it crashes?

-- Reuti

> The trouble is that mpiexec passes a command which looks like this:
>
> ( . ./.profile ..... )
>
> which, however, is not a valid exec argument...
>
> Is there any way to tell mpiexec to run it in a separate script??? Any
> idea how to solve this???
>
> Thanx
> Ondrej Glembek
>
> --
>
> Ondrej Glembek, PhD student E-mail: glembek_at_[hidden]
> UPGM FIT VUT Brno, L226 Web: http://www.fit.vutbr.cz/
> ~glembek
> Bozetechova 2, 612 66 Phone: +420 54114-1292
> Brno, Czech Republic Fax: +420 54114-1290
>
> ICQ: 93233896
> GPG: C050 A6DC 7291 6776 9B69 BB11 C033 D756 6F33 DE3C
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users