Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PGI 10.0 configure fails (OMPI 1.3.3)
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-11-24 20:59:33


There were 2 issues in Libtool itself (one of the tools that is used
to automatically create OMPI's configure script). PGI supplied one
patch to the GNU Libtool maintainers; they slightly modified that
patch and fixed the 2nd issue as well:

     http://lists.gnu.org/archive/html/bug-libtool/2009-11/msg00045.html
     http://lists.gnu.org/archive/html/bug-libtool/2009-11/msg00067.html

These fixes will be included in the next Libtool release. However, I
don't know when that will be, so I guess we'll need to put patches in
OMPI as well. I'll open a bug to ensure that we do this.

But I'm literally about to head out for the US Thanksgiving holiday.
So I won't be able to get to this until next week - sorry... If
you're desperate for a fix, the two URLs above might give you enough
information to get you going until we can fix it properly in OMPI.

On Nov 24, 2009, at 8:11 PM, Scott Beardsley wrote:

> There appears to be a workaround posted on the forum[1].
>
> I applied that "fix" but noticed no differences. Perhaps Jeff Squyres
> can add some insight?
>
> Thanks
> Scott
> ------------
> [1] http://www.pgroup.com/userforum/viewtopic.php?p=6114
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Jeff Squyres
jsquyres_at_[hidden]