Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with mpirun -preload-binary option
From: Qing Pang (qing.pang_at_[hidden])
Date: 2009-11-11 11:16:47


Thank you very much for your help! I believe I do have password-less ssh
set up, at least from master node to client node (desktop -> laptop in
my case). If I type >ssh node1 on my desktop terminal, I am able to get
to the laptop node without being asked for password. And as I mentioned,
if I copy the example executable from desktop to the laptop node using
scp, then I am able to run it from desktop using both nodes.
Back to the preload-binary problem - I am asked for the password of my
master node - the node I am working on - not the remote client node. Do
you mean that I should set up password-less ssh in both direction? Does
the client node need to access master node through password-less ssh to
make the preload-binary option work?

Ralph Castain Wrote:

It -should- work, but you need password-less ssh setup. See our FAQ
for how to do that, if you are unfamiliar with it.

On Nov 10, 2009, at 2:02 PM, Qing Pang wrote:

I'm having problem getting the mpirun "preload-binary" option to work.
>
> I'm using ubutu8.10 with openmpi 1.3.3, nodes connected with Ethernet
> cable.
> If I copy the executable to client nodes using scp, then do mpirun,
> everything works.
>
> But I really want to avoid the copying, so I tried the -preload-binary
> option.
>
> When I typed the command on my master node as below (gordon-desktop is
> my master node, and gordon-laptop is the client node):
>
> --------------------------------------------------------------------------
>
> gordon_at_gordon-desktop:~/Desktop/openmpi-1.3.3/examples$ mpirun
> -machinefile machine.linux -np 2 --preload-binary $(pwd)/hello_c.out
> --------------------------------------------------------------------------
>
>
> I got the following:
>
> gordon_at_gordon-desktop's password: (I entered my password here, why
> am I asked for the password? I am working under this account anyway)
>
>
> WARNING: Remote peer ([[18118,0],1]) failed to preload a file.
>
> Exit Status: 256
> Local File:
> /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/hello_c.out
> Remote File: /home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
> Command:
> scp
> gordon-desktop:/home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
> /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/hello_c.out
>
> Will continue attempting to launch the process(es).
> --------------------------------------------------------------------------
>
> --------------------------------------------------------------------------
>
> mpirun was unable to launch the specified application as it could not
> access
> or execute an executable:
>
> Executable: /home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
> Node: node1
>
> while attempting to start process rank 1.
> --------------------------------------------------------------------------
>
>
> Had anyone succeeded with the 'preload-binary' option with the similar
> settings? I assume this mpirun option should work when compiling
> openmpi with default options? Anything I need to set?
>
> --qing
>
>