Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with mpirun -preload-binary option
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-11-10 16:41:07


It -should- work, but you need password-less ssh setup. See our FAQ
for how to do that, if you are unfamiliar with it.

On Nov 10, 2009, at 2:02 PM, Qing Pang wrote:

> I'm having problem getting the mpirun "preload-binary" option to work.
>
> I'm using ubutu8.10 with openmpi 1.3.3, nodes connected with
> Ethernet cable.
> If I copy the executable to client nodes using scp, then do mpirun,
> everything works.
>
> But I really want to avoid the copying, so I tried the -preload-
> binary option.
>
> When I typed the command on my master node as below (gordon-desktop
> is my master node, and gordon-laptop is the client node):
>
> --------------------------------------------------------------------------
> gordon_at_gordon-desktop:~/Desktop/openmpi-1.3.3/examples$ mpirun
> -machinefile machine.linux -np 2 --preload-binary $(pwd)/hello_c.out
> --------------------------------------------------------------------------
>
> I got the following:
>
> gordon_at_gordon-desktop's password: (I entered my password here,
> why am I asked for the password? I am working under this account
> anyway)
>
>
> WARNING: Remote peer ([[18118,0],1]) failed to preload a file.
>
> Exit Status: 256
> Local File: /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/
> hello_c.out
> Remote File: /home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
> Command:
> scp gordon-desktop:/home/gordon/Desktop/openmpi-1.3.3/examples/
> hello_c.out
> /tmp/openmpi-sessions-gordon_at_gordon-laptop_0/18118/0/hello_c.out
>
> Will continue attempting to launch the process(es).
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun was unable to launch the specified application as it could
> not access
> or execute an executable:
>
> Executable: /home/gordon/Desktop/openmpi-1.3.3/examples/hello_c.out
> Node: node1
>
> while attempting to start process rank 1.
> --------------------------------------------------------------------------
>
> Had anyone succeeded with the 'preload-binary' option with the
> similar settings? I assume this mpirun option should work when
> compiling openmpi with default options? Anything I need to set?
>
> --qing
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users