Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ipo: warning #11009: file format not recognized for /Libraries_intel/openmpi/lib/libmpi.so
From: Nifty Tom Mitchell (niftyompi_at_[hidden])
Date: 2009-11-10 12:35:49


On Tue, Nov 10, 2009 at 03:44:59PM +0200, vasilis gkanis wrote:
>
> I am trying to compile openmpi-1.3.3 with intel Fortran and gcc compiler.
>
> In order to compile openmpi I run configure with the following options:
>
> ./configure --prefix=/Libraries/openmpi FC=ifort --enable-mpi-f90
>
> OpenMpi compiled just fine, but when I am trying to compile and link my program
> against mpi, I get the following error:
>
> ipo: warning #11009: file format not recognized for
> /Libraries_intel/openmpi/lib/libmpi.so
> ld: skipping incompatible /Libraries_intel/openmpi/lib/libmpi.so when
> searching for -lmpi
> ld: cannot find -lmpi
>
> I have updated the LD_LIBRARY_PATH file.
>
> Does anybody know what this error mean?

What does:
         file /Libraries_intel/openmpi/lib/libmpi.so
tell you?

Perhaps this is a 32bit .vs. 64bit mismatch?

-- 
	T o m  M i t c h e l l 
	Found me a new hat, now what?