Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Openmpi on Heterogeneous environment
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-11-10 07:56:47


Do you see any output from your executables? I.e., are you sure that
it's running the "correct" executables? If so, do you know how far
it's getting in its run before aborting?

On Nov 10, 2009, at 7:36 AM, Yogesh Aher wrote:

> Thanks for the reply Pallab. Firewall is not an issue as I can
> passwordless-SSH to/from both machines.
> My problem is to deal with 32bit & 64bit architectures
> simultaneously (and not with different operating systems). Can it be
> possible through open-MPI???
>
> Look forward to the solution!
>
> Thanks,
> Yogesh
>
>
> From: Pallab Datta (datta_at_[hidden])
>
> I have had issues for running in cross platforms..ie. Mac OSX and
> Linux
> (Ubuntu)..haven't got it resolved..check firewalls if thats blocking
> any
> communication..
>
> On Thu, Nov 5, 2009 at 7:47 PM, Yogesh Aher <aher.yogesh_at_[hidden]>
> wrote:
> Dear Open-mpi users,
>
> I have installed openmpi on 2 different machines with different
> architectures (INTEL and x86_64) separately (command: ./configure --
> enable-heterogeneous). Compiled executables of the same code for
> these 2 arch. Kept these executables on individual machines.
> Prepared a hostfile containing the names of those 2 machines.
> Now, when I want to execute the code (giving command - ./mpirun -
> hostfile machines executable), it doesn't work, giving error message:
>
> MPI_ABORT was invoked on rank 2 in communicator MPI_COMM_WORLD
> with errorcode 1.
>
> NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
> You may or may not see output from other processes, depending on
> exactly when Open MPI kills them.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun has exited due to process rank 2 with PID 1712 on
> node studpc1.xxx.xxxx.xx exiting without calling "finalize". This may
> have caused other processes in the application to be
> terminated by signals sent by mpirun (as reported here)
>
> When I keep only one machine-name in the hostfile, then the
> execution works perfect.
>
> Will anybody please guide me to run the program on heterogeneous
> environment using mpirun!
>
> Thanking you,
>
> Sincerely,
> Yogesh
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]