Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mpirun noticed that process rank 1 ... exited on signal 13 (Broken pipe).
From: Kritiraj Sajadah (ksajadah_at_[hidden])
Date: 2009-11-06 10:59:23


Hi Everyone,
              I have install openmpi 1.3 and blcr 0.81 on my laptop (single processor).

I am trying to checkpoint a small test application:

###########

#include <mpi.h>
#include <stdio.h>
#include <stdlib.h>
#include<unistd.h>
#include<signal.h>

int main(int argc, char **argv)
{
int rank,size;
MPI_Init(&argc, &argv);
MPI_Comm_rank(MPI_COMM_WORLD, &rank);
MPI_Comm_size(MPI_COMM_WORLD, &size);
printf("I am processor no %d of a total of %d procs \n", rank, size);
system("sleep 10");
printf("I am processor no %d of a total of %d procs \n", rank, size);
system("sleep 10");
printf("I am processor no %d of a total of %d procs \n", rank, size);
system("sleep 10");
printf("mpisleep bye \n");
MPI_Finalize();
return 0;
}
###################

I compile it as follows:

mpicc mpisleep.c -o mpisleep

and i run it as follows:

mpirun -am ft-enable-cr -np 2 mpisleep.

When i try checkpointing ( ompi-checkpoint -v 8118) it, it checkpoints fine but when i restart it, i get the following:

I am processor no 0 of a total of 2 procs
I am processor no 1 of a total of 2 procs
mpisleep bye
--------------------------------------------------------------------------
mpirun noticed that process rank 1 with PID 8118 on node raj-laptop exited on signal 13 (Broken pipe).
--------------------------------------------------------------------------

Any suggestions is very much appreciated

Raj