Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Openmpi on Heterogeneous environment
From: Pallab Datta (datta_at_[hidden])
Date: 2009-11-05 13:53:54


I have had issues for running in cross platforms..ie. Mac OSX and Linux
(Ubuntu)..haven't got it resolved..check firewalls if thats blocking any
communication..

> Dear Open-mpi users,
>
> I have installed openmpi on 2 different machines with different
> architectures (INTEL and x86_64) separately (command: ./configure
> --enable-heterogeneous). Compiled executables of the same code for these 2
> arch. Kept these executables on individual machines. Prepared a hostfile
> containing the names of those 2 machines.
> Now, when I want to execute the code (giving command - ./mpirun -hostfile
> machines executable), it doesn't work, giving error message:
>
> MPI_ABORT was invoked on rank 2 in communicator MPI_COMM_WORLD
> with errorcode 1.
>
> NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
> You may or may not see output from other processes, depending on
> exactly when Open MPI kills them.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun has exited due to process rank 2 with PID 1712 on
> node studpc1.xxx.xxxx.xx exiting without calling "finalize". This may
> have caused other processes in the application to be
> terminated by signals sent by mpirun (as reported here)
>
> When I keep only one machine-name in the hostfile, then the execution
> works
> perfect.
>
> Will anybody please guide me to run the program on heterogeneous
> environment
> using mpirun!
>
> Thanking you,
>
> Sincerely,
> Yogesh
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users