Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Checkpoint/Restart in OpenMPI
From: Sergio Díaz (sdiaz_at_[hidden])
Date: 2009-11-02 07:56:39


The mpi.h file is also in the installation dir. It is in the include
directory of your installation.
I think that it is a path problem...

Andreea m. (Costea) escribió:
> MPI_HOME is set to be /home/andreea/MPIrelated/OpenMPI/openmpi_1.3.3
> But as far as I see it needs files that are only in SOURCES... so
> maybe I did something wrong in the installation of OpenMPI?
> If I run an already compiled file it works fine, of course. But it
> does not compile
>
> --- On *Mon, 11/2/09, Sergio Díaz /<sdiaz_at_[hidden]>/* wrote:
>
>
> From: Sergio Díaz <sdiaz_at_[hidden]>
> Subject: Re: [OMPI users] Checkpoint/Restart in OpenMPI
> To: "Open MPI Users" <users_at_[hidden]>
> Date: Monday, November 2, 2009, 2:36 PM
>
> Maybe the variable MPI_HOME??
>
>
>
> Andreea m. (Costea) escribió:
> > Ok...
> > Maybe someone can clear me :)
> >
> > I have BLCR sources in this directory :
> > /home/andreea/MPIrelated/BLCR/blcr-0.8.2
> > it's installation is in this directory:
> > /home/andreea/MPIrelated/BLCR/blcr-0.8.2/builddir
> >
> > OpenMPI:
> > sources: /home/andreea/MPIrelated/OpenMPI/SOURCES
> > installation: /home/andreea/MPIrelated/OpenMPI/openmpi_1.3.3
> >
> > I added to the variables (PATH, LD_LIBRARY_PATH) teh paths from the
> > installation directories:
> > for PATH I added:
> /home/andreea/MPIrelated/BLCR/blcr-0.8.2/builddir/bin
> >
> > /home/andreea/MPIrelated/OpenMPI/openmpi_1.3.3/bin
> > fro LD_LIBRARY_PATH:
> /home/andreea/MPIrelated/BLCR/blcr-0.8.2/builddir/lib
> >
> > /home/andreea/MPIrelated/OpenMPI/openmpi_1.3.3/lib
> >
> > If I want to compile a c program, MPI based, I get errors of not
> > finding the mpi.h (which is located in the OpenMPI/SOURCES/include
> > directory). It can't also find the constants like:
> > MPI_COMM_WORLD,MPI_INT, etc.
> >
> > Help, anyone?
> > Thanks,
> > Andreea
> >
> >
> > --- On *Mon, 11/2/09, Sergio Díaz /<sdiaz_at_[hidden]
> </mc/compose?to=sdiaz_at_[hidden]>>/* wrote:
> >
> >
> > From: Sergio Díaz <sdiaz_at_[hidden]
> </mc/compose?to=sdiaz_at_[hidden]>>
> > Subject: Re: [OMPI users] Checkpoint/Restart in OpenMPI for
> Sergio
> > To: "Open MPI Users" <users_at_[hidden]
> </mc/compose?to=users_at_[hidden]>>
> > Date: Monday, November 2, 2009, 1:12 PM
> >
> > Hi,
> >
> > The option --enable-ft-thread doesn't exist. By default is
> enable.
> > The options --with-blcr and --with-blcr-libdir have to point to
> > your BLCR installation dir.
> > Before compiling openmpi, you have to load the blcr modules.
> >
> > When I installed BLCR, my installation dir was in a different
> > directory.
> >
> > Regards,
> > Sergio
> >
> >
> >
> > Andreea m. (Costea) escribió:
> >> One more thing:
> >> when you installed BLCR did you install it in the same
> directory
> >> with the sources or in a different one? And when you point
> to the
> >> blcr directory and the blcr library directory in openmpi
> >> configure command, do you point to the installation or to the
> >> sources directory?
> >>
> >> Regards,
> >> Andreea
> >>
> >> --- On *Mon, 11/2/09, Andreea m. (Costea)
> >> /<doodlie_snew_at_[hidden]
> </mc/compose?to=doodlie_snew_at_[hidden]>>/* wrote:
> >>
> >>
> >> From: Andreea m. (Costea) <doodlie_snew_at_[hidden]
> </mc/compose?to=doodlie_snew_at_[hidden]>>
> >> Subject: Re: [OMPI users] Checkpoint/Restart in OpenMPI
> >> To: "Open MPI Users" <users_at_[hidden]
> </mc/compose?to=users_at_[hidden]>>
> >> Date: Monday, November 2, 2009, 7:02 AM
> >>
> >> Hi again.
> >>
> >> I have installed BLCR, passed all the tests, and now I
> tried
> >> to install OpenMPI. This is the configuration call:
> >>
> --------------------------------------------------------------------------------------------------
> >> ./configure
> >> --prefix=/home/andreea/MPIrelated/OpenMPI/openmpi_1.3.3/
> >> --enable-ft-thread --with-ft=cr --enable-mpi-threads
> >>
> --with-blcr=/home/andreea/MPIrelated/BLCR/blcr-0.8.2/builddir/
> >>
> --with-blcr-libdir=/home/andreea/MPIrelated/BLCR/blcr-0.8.2/builddir/lib
> >>
> --------------------------------------------------------------------------------------------------
> >>
> >> In the output I got, among others, this warnings:
> >>
> >> configure: WARNING: no usable BFD found; using
> nm-output file
> >> for addr./symbol mapping
> >> configure: WARNING: Unrecognized options:
> --enable-ft-thread,
> >> --with-ft, --enable-mpi-threads, --with-blcr,
> >> --with-blcr-libdir, --enable-ltdl-convenience
> >> configure: WARNING: Unrecognized options:
> --enable-ft-thread,
> >> --with-ft, --enable-mpi-threads, --with-blcr,
> >> --with-blcr-libdir, --enable-ltdl-convenience
> >>
> >> Any ideas?
> >> Thanks,
> >> Andreea
> >> --- On *Fri, 10/30/09, Sergio Díaz /<sdiaz_at_[hidden]
> </mc/compose?to=sdiaz_at_[hidden]>>/* wrote:
> >>
> >>
> >> From: Sergio Díaz <sdiaz_at_[hidden]
> </mc/compose?to=sdiaz_at_[hidden]>>
> >> Subject: Re: [OMPI users] Checkpoint/Restart in OpenMPI
> >> To: "Open MPI Users" <users_at_[hidden]
> </mc/compose?to=users_at_[hidden]>>
> >> Date: Friday, October 30, 2009, 11:28 AM
> >>
> >> Hi Andreea,
> >>
> >> I compiled an installation of openmpi with
> >> checkpoint/restart support and it is working fine
> and I'm
> >> trying to integrate it with SGE.
> >> Did you set the right option compiling openMPI?
> >> Did you installed BLCR before?
> >>
> >> I used these options:
> >>
> >> ./configure --prefix=/opt/cesga/openmpi-1.3.3
> >> --with-ft=cr --enable-mpi-threads
> >> --with-blcr=/opt/cesga/blcr-0.8.2
> >> --with-blcr-libdir=/opt/cesga/blcr-0.8.2/lib -with-sge
> >> CC=icc CXX=icpc F77=ifort FC=ifort
> >>
> >> Regards,
> >> Sergio
> >>
> >> Andreea m. (Costea) escribió:
> >>> Hi,
> >>>
> >>> I'm a newbie, and I want to test the
> checkpoint/restart
> >>> mechanism included in OpenMPI v 1.3.3. I have tried to
> >>> search for some documentation about how to install the
> >>> OpenMPI implementation in order to support
> >>> checkpoint/restart, and I found lots of links to
> >>>
> >>> https://svn.open-mpi.org/trac/ompi/wiki/ProcessFT_CR
> >>>
> >>> which seems not to work. Can you please advise me what
> >>> to read or what steps to follow in order to have
> >>> everything working?
> >>>
> >>> I already installed OpenMPI but checkpoint/restart
> >>> doesn't work. During installation, in installation
> log I
> >>> found teh following lines (don't know if it's my
> >>> software configuration fault or the way I installed
> >>> OpenMPI):
> >>>
> --------------------------------------------------------------------------------
> >>> --- MCA component pml:crcpw (m4 configuration macro)
> >>> checking for MCA component pml:crcpw compile
> mode... dso
> >>> checking if MCA component pml:crcpw can compile... no
> >>>
> >>> +++ Configuring MCA framework crcp
> >>> checking for no configure components in framework
> crcp...
> >>> checking for m4 configure components in framework
> >>> crcp... bkmrk
> >>>
> >>> --- MCA component crcp:bkmrk (m4 configuration macro)
> >>> checking for MCA component crcp:bkmrk compile
> mode... dso
> >>> checking if MCA component crcp:bkmrk can compile... no
> >>>
> --------------------------------------------------------------------------------
> >>>
> >>> Thanks,
> >>> Andreea
> >>>
> >>>
> >>>
> >>>
> ------------------------------------------------------------------------
> >>>
> >>> _______________________________________________
> >>> users mailing list
> >>> users_at_[hidden] </mc/compose?to=users_at_[hidden]>
> >>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >>
> >> --
> >> Sergio Díaz Montes
> >> Centro de Supercomputacion de Galicia
> >> Avda. de Vigo. s/n (Campus Sur) 15706 Santiago de
> >> Compostela (Spain)
> >> Tel: +34 981 56 98 10 ; Fax: +34 981 59 46 16
> >> email: sdiaz_at_[hidden]
> </mc/compose?to=sdiaz_at_[hidden]> ; http://www.cesga.es/
> >>
> >> ------------------------------------------------
> >>
> >>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Sergio Díaz Montes
Centro de Supercomputacion de Galicia
Avda. de Vigo. s/n (Campus Sur) 15706 Santiago de Compostela (Spain)
Tel: +34 981 56 98 10 ; Fax: +34 981 59 46 16
email: sdiaz_at_[hidden] ; http://www.cesga.es/
------------------------------------------------