Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Fortran Library Problem using openMPI
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-10-30 08:23:45


A copy of the configure line for Open MPI would be helpful. Which Intel
compiler are you using, version and bitness. Can you do file on
libmpi_f77.so? Also, are you sure that /usr/local/lib is where you
installed you Open MPI build and that isn't something latent?

--td
> Date: Fri, 30 Oct 2009 12:45:07 +0100
> From: "Georg A. Reichstein" <reichstein_at_[hidden]>
> Subject: [OMPI users] Fortran Library Problem using openMPI
> To: <users_at_[hidden]>
> Message-ID: <D49F4D3BCDB3460AA6F2C204044FD298_at_[hidden]>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi!
>
>
>
> I?m trying to compile a Fortran file. I did not code it myself and am not
> familiar with it?s detailed workings ? I?m interested in the program it will
> result in after compiling.
>
> Along with the file I also received a command line.
>
> My OS is openSuse 11.1. As I need openMPI and the Intel compiler is
> recommended I downloaded both and installed them. I ? hopefully ? configured
> openMPI in the right way. When I run the command I get the following result
> (<file>.f is the name of the Fortran code that I got):
>
>
>
> # mpif77 -O3 -ip -pad -xW -o <file> <file>.f
>
> ld: skipping incompatible /usr/local/lib/libmpi_f77.so when searching for
> -lmpi_f77
>
> ld: skipping incompatible /usr/local/lib/libmpi_f77.so when searching for
> -lmpi_f77
>
> ld: cannot find -lmpi_f77
>
>
>
> Obviously there is an issue with the library lmpi_f77. The file
> /usr/local/lib/libmpi_f77.so exists ? I just do not know how to check it and
> find out why it is labelled ?incompatible?.
>
> I have attached all logs from ./configure, make all and make install as
> mentioned on the openMPI website. They are compressed in a single folder.
>
> I very much appreciate your help! Please feel free to contact me about
> further details where needed.
>
> Thanks
>
> Georg
>
>
>
> PS
>
> I also tried to find help in a few forums on the net ? but without success.
>
>