Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] memchecker overhead?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-10-26 16:21:31


There's a whole class of valgrind warnings that are generated when you
use OS-bypass networks like OpenFabrics. The verbs library and Open
MPI can be configured and compiled with additional instructions that
tell Valgrind where the "problematic" spots are, and that the memory
is actually ok (because it's memory that came from outside of
Valgrind's scope of influence). Verbs and Open MPI don't have these
options on by default because a) you need to compile against
Valgrind's header files to get them to work, and b) there's a tiny/
small amount of overhead inserted by OMPI telling Valgrind "this
memory region is ok", but we live in an intensely competitive HPC
environment.

The option to enable this Valgrind Goodness in OMPI is --with-
valgrind. I *think* the option may be the same for libibverbs, but I
don't remember offhand.

That being said, I'm guessing that we still have bunches of other
valgrind warnings that may be legitimate. We can always use some help
to stamp out these warnings... :-)

On Oct 26, 2009, at 4:09 PM, Jed Brown wrote:

> Samuel K. Gutierrez wrote:
> > Hi Jed,
> >
> > I'm not sure if this will help, but it's worth a try. Turn off
> OMPI's
> > memory wrapper and see what happens.
> >
> > c-like shell
> > setenv OMPI_MCA_memory_ptmalloc2_disable 1
> >
> > bash-like shell
> > export OMPI_MCA_memory_ptmalloc2_disable=1
> >
> > Also add the following MCA parameter to you run command.
> >
> > --mca mpi_leave_pinned 0
>
> Thanks for the tip, but these make very little difference.
>
> Jed
>
>
> <signature.asc>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]