Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] memchecker overhead?
From: Samuel K. Gutierrez (samuel_at_[hidden])
Date: 2009-10-26 15:59:16


Hi Jed,

I'm not sure if this will help, but it's worth a try. Turn off OMPI's
memory wrapper and see what happens.

c-like shell
setenv OMPI_MCA_memory_ptmalloc2_disable 1

bash-like shell
export OMPI_MCA_memory_ptmalloc2_disable=1

Also add the following MCA parameter to you run command.

--mca mpi_leave_pinned 0

--
Samuel K. Gutierrez
Los Alamos National Laboratory
On Oct 26, 2009, at 1:41 PM, Jed Brown wrote:
> Jeff Squyres wrote:
>> Using --enable-debug adds in a whole pile of developer-level run-time
>> checking and whatnot.  You probably don't want that on production  
>> runs.
>
> I have found that --enable-debug --enable-memchecker actually produces
> more valgrind noise than leaving them off.  Are there options to make
> Open MPI strict about initializing and freeing memory?  At one point I
> tried to write policy files, but even with judicious globbing, I kept
> getting different warnings when run on a different program.  (All  
> these
> codes were squeaky-clean under MPICH2.)
>
> Jed
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users