Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Making RPM from source that respects --prefix
From: Kiril Dichev (dichev_at_[hidden])
Date: 2009-10-02 08:59:44


Hi Bill,

you might want to have a look here if you need a working example of
that:

https://savannah.fzk.de/cgi-bin/viewcvs.cgi/trunk/?root=openmpi-build

We used to generate both SRPMs and RPMs for Open MPI in a previous
project and did in fact specify a separate installation directory :
(%define ompi_prefix /opt/i2g/openmpi in i2g-openmpi.spec.in)

Hope that helps.

Regards,
Kiril

On Fri, 2009-10-02 at 03:48 -0700, Bill Johnstone wrote:
> I'm trying to build an RPM of 1.3.3 from the SRPM. Despite typical RPM practice, I need to build ompi so that it installs to a different directory from /usr or /opt, i.e. what I would get if I just built from source myself with a --prefix argument to configure.
>
> When I invoke buildrpm with the --define 'configure_options --prefix=<desired path> ...', the options do get set when the building process gets kicked off. However, when I query the final RPM, only vampirtrace has paid attention to the specified --prefix and wants to place its files accordingly. How should I alter the .spec file (or in some other place?) to get the desired behavior for the final file locations in the RPM?
>
> Thank you for any help.
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Dipl.-Inf. Kiril Dichev
Tel.: +49 711 685 60492
E-mail: dichev_at_[hidden]
High Performance Computing Center Stuttgart (HLRS)
Universität Stuttgart
70550 Stuttgart
Germany