Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Openmpi setup with intel compiler.
From: vighnesh_at_[hidden]
Date: 2009-10-01 01:25:16


Dear Peter,
    Your suggestions did worked, it didnt showed any error during make and
make install. But it didnt got installed with mpif90 support. I tried to
compile my mpi code, but it gave following error.

[vighnesh_at_test_node SIVA]$ /share/apps/mpi/openmpi/intel/bin/mpif90 code.f
-o code.exe
--------------------------------------------------------------------------
Unfortunately, this installation of Open MPI was not compiled with
Fortran 90 support. As such, the mpif90 compiler is non-functional.
--------------------------------------------------------------------------

 My configure script line is:
[root_at_test_node vighnesh]# ./configure
--prefix=/share/apps/mpi/openmpi/intel FC=ifort --with-tm=/opt/torque

Please help me.

Thanks and Regards,
Vighnesh

> On Wednesday 30 September 2009, vighnesh_at_[hidden] wrote:
> ...
>> during
>> configuring with Intel 9.0 compiler the installation gives following
>> error.
>>
>> [root_at_test_node openmpi-1.3.3]# make all install
> ...
>> make[3]: Entering directory `/tmp/openmpi-1.3.3/orte'
>> test -z "/share/apps/mpi/openmpi/intel/lib" || /bin/mkdir -p
>> "/share/apps/mpi/openmpi/intel/lib"
>> /bin/sh ../libtool --mode=install /usr/bin/install -c
>> 'libopen-rte.la'
>> '/share/apps/mpi/openmpi/intel/lib/libopen-rte.la'
>> libtool: install: error: cannot install `libopen-rte.la' to a directory
>> not ending in /share/apps/mpi/openmpi/pgi/lib
>
> The line above indicates that you've somehow attempted this from a dirty
> tree
> and/or environment (dirty from the previous pgi installation...).
>
> Try a clean environment, clean build tree. Source the icc/ifort-vars.sh
> files
> from your intel install dir, set CC, CXX, FC, F77 and do:
> "./configure --prefix=... && make && make install"
>
> /Peter
>