Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] how to set up the cluster of 5 nodes in openmpi
From: jody (jody.xha_at_[hidden])
Date: 2009-09-30 06:09:06


Hi
All of your questions are answered in the FAQ...

If you have a TCP/IP connection between your machines so that each
machine can reach every other one,
that will be ok.

First make sure you can get access from each machine to every other
one using ssh without a password.
See the FAQ:
  http://www.open-mpi.org/faq/?category=rsh

Make sure to set PATH and LD_LIBRARY_PATH as described in the FAQ:
  http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path

Next, make sure your application is accessible by all of your
machines. I use an nfs directory shared by all my machines,
and that is where i put the application.

To start your application, follow the instructions in the FAQ:
   http://www.open-mpi.org/faq/?category=running

If you want to use host files, read about how to use them in the FAQ:
  http://www.open-mpi.org/faq/?category=running#mpirun-host

Hope that helps

Jody

On Wed, Sep 30, 2009 at 11:00 AM, ankur pachauri
<ankurpachauri_at_[hidden]> wrote:
> Dear all,
>
> I have been able to install open mpi on two independent machines having FC
> 10. The simple hello world programms are running fine on the independent
> machines....But can any one pls help me by letting me know how to connect
> the two machines and run a common program between the two....how do we a do
> a lamboot -v lamhosts in case of openmpi?
> How do we get the open mpi running on the two computers simultaneously and
> excute a common program on the two machines.
>
> Thanks in advance
>
>
> On Wed, Sep 30, 2009 at 12:24 PM, jody <jody.xha_at_[hidden]> wrote:
>>
>> Hi
>> Have look at the Open MPI FAQ:
>>
>>  http://www.open-mpi.org/faq/
>>
>> It gives you all the information you need to start working with your
>> cluster.
>>
>> Jody
>>
>>
>> On Wed, Sep 30, 2009 at 8:25 AM, ankur pachauri <ankurpachauri_at_[hidden]>
>> wrote:
>> > dear all,
>> >
>> > i am new to openmpi, all that i need is to set up the cluster of around
>> > 5
>> > nodes in my lab, i am using fedora 7 in the lab. so i'll be thankfull to
>> > you
>> > if let me know the steps or the procedure to setup the cluster(as in
>> > case of
>> > lam/mpi- passwordless ssh or nfs mount and ...).
>> >
>> > regards,
>> >
>> > --
>> > Ankur Pachauri.
>> > 09927590910
>> >
>> > Research Scholar,
>> > software engineering.
>> > Department of Mathematics
>> > Dayalbagh Educational Institute
>> > Dayalbagh,
>> > AGRA
>> >
>> > _______________________________________________
>> > users mailing list
>> > users_at_[hidden]
>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>> >
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> --
> Ankur Pachauri.
> 09927590910
>
> Research Scholar,
> software engineering.
> Department of Mathematics
> Dayalbagh Educational Institute
> Dayalbagh,
> AGRA
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>