Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] segfault on finalize
From: Thomas Ropars (tropars_at_[hidden])
Date: 2009-09-28 04:02:15


You are right. An update fixes the problem.

Sorry.

Thomas

Jeff Squyres wrote:
> It's a fairly strange place to get an error --
> mca_base_param_finalize() is where we're tidying up command line
> parameters.
>
> There was some memory bugs that have been fixed since 21970. Can you
> update?
>
>
> On Sep 25, 2009, at 9:49 AM, Thomas Ropars wrote:
>
>> Hi,
>>
>> I'm using r21970 of the trunk on Linux 2.6.18-3-amd64 and gcc version
>> 4.2.3 (Debian 4.2.3-2).
>>
>> When I compile open mpi with the default options, it works.
>> But if I use --with-platform=optimized option, then I get a segfault for
>> every program I run.
>>
>> ==3073== Access not within mapped region at address 0x30
>> ==3073== at 0x535544D: mca_base_param_finalize (in
>> /home/tropars/open-mpi/install/lib/libopen-pal.so.0.0.0)
>> ==3073== by 0x5339D55: opal_finalize_util (in
>> /home/tropars/open-mpi/install/lib/libopen-pal.so.0.0.0)
>> ==3073== by 0x4E5A228: ompi_mpi_finalize (in
>> /home/tropars/open-mpi/install/lib/libmpi.so.0.0.0)
>> ==3073== by 0x400BF2: main (in /home/tropars/open-mpi/tests/ring)
>>
>> Regards,
>>
>> Thomas
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>