Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] running open mpi on ubuntu 9.04
From: Pavel Shamis (Pasha) (pashash_at_[hidden])
Date: 2009-09-21 04:09:38


You will not be need the trick if you will configure Open Mpi with
follow flag:
--enable-mpirun-prefix-by-default

Pasha.

Hodgess, Erin wrote:
>
> the LD_LIBRARY_PATH did the trick;
> thanks so much!
>
> Sincerely,
> Erin
>
>
> Erin M. Hodgess, PhD
> Associate Professor
> Department of Computer and Mathematical Sciences
> University of Houston - Downtown
> mailto: hodgesse_at_[hidden]
>
>
>
> -----Original Message-----
> From: users-bounces_at_[hidden] on behalf of Marce
> Sent: Sat 9/19/2009 3:54 PM
> To: Open MPI Users
> Subject: Re: [OMPI users] running open mpi on ubuntu 9.04
>
> 2009/9/18 Hodgess, Erin <HodgessE_at_[hidden]>:
> > There is no hosts file there originally
> > I put in
> >
> > cat hosts
> > 127.0.0.1 localhost
> >
> >
> > but still get the same thing
> >
> > thanks,
> > Erin
> >
> > erin_at_erin-laptop:~$
> > Erin M. Hodgess, PhD
> > Associate Professor
> > Department of Computer and Mathematical Sciences
> > University of Houston - Downtown
> > mailto: hodgesse_at_[hidden]
> >
> >
> >
> > -----Original Message-----
> > From: users-bounces_at_[hidden] on behalf of Whit Armstrong
> > Sent: Fri 9/18/2009 7:36 AM
> > To: Open MPI Users
> > Subject: Re: [OMPI users] running open mpi on ubuntu 9.04
> >
> > yes, I had this issue before (we are on 9.04 as well).
> > it has to do with the hosts file.
> >
> > Erin, can you send your hosts file?
> >
> > I think you want to make this the first line of your host file:
> > 127.0.0.1 localhost
> >
> > Which Ubuntu, if memory serves defaults to the name of the machine
> instead
> > of localhost.
> >
> > -Whit
> >
> >
> > On Fri, Sep 18, 2009 at 8:31 AM, Ralph Castain <rhc_at_[hidden]> wrote:
> >
> >> It doesn't matter - 1.3 isn't going to launch another daemon on the
> local
> >> node.
> >> The problem here is that OMPI isn't recognizing your local host as
> being
> >> "local" - i.e., it thinks that the host mpirun is executing on is
> somehow
> >> not the the local host. This has come up before with ubuntu - you might
> >> search the user mailing list for "ubuntu" to see earlier threads on
> this
> >> issue.
> >>
> >> I forget the final solution, but those earlier threads will explain
> what
> >> needs to be done. I'm afraid this is something quite specific to
> ubuntu.
> >>
> >>
> >> On Sep 18, 2009, at 6:23 AM, Whit Armstrong wrote:
> >>
> >> can you "ssh localhost" without a password?
> >> -Whit
> >>
> >>
> >> On Thu, Sep 17, 2009 at 11:50 PM, Hodgess, Erin <HodgessE_at_[hidden]>
> wrote:
> >>
> >>> It's 1.3, please.
> >>>
> >>> Thanks,
> >>>
> >>> Erin
> >>>
> >>>
> >>> Erin M. Hodgess, PhD
> >>> Associate Professor
> >>> Department of Computer and Mathematical Sciences
> >>> University of Houston - Downtown
> >>> mailto: hodgesse_at_[hidden]
> >>>
> >>>
> >>>
> >>> -----Original Message-----
> >>> From: users-bounces_at_[hidden] on behalf of Ralph Castain
> >>> Sent: Thu 9/17/2009 10:39 PM
> >>> To: Open MPI Users
> >>> Subject: Re: [OMPI users] running open mpi on ubuntu 9.04
> >>>
> >>> I gather you must be running a version of the old 1.2 series? Or are
> >>> you running 1.3?
> >>>
> >>> It does make a difference as to the nature of the problem, and the
> >>> recommended solution.
> >>>
> >>> Thanks
> >>> Ralph
> >>>
> >>> On Sep 17, 2009, at 8:51 PM, Hodgess, Erin wrote:
> >>>
> >>> > Dear Open MPI people:
> >>> >
> >>> > I'm trying to run a simple "hello world" program on Ubuntu 9.04
> >>> >
> >>> > It's on a dual core laptop; no other machines.
> >>> >
> >>> > Here is the output:
> >>> > erin_at_erin-laptop:~$ mpirun -np 2 a.out
> >>> > ssh: connect to host erin-laptop port 22: Connection refused
> >>> >
> >>>
> >>>
> --------------------------------------------------------------------------
> >>> > A daemon (pid 11854) died unexpectedly with status 255 while
> >>> > attempting
> >>> > to launch so we are aborting.
> >>> >
> >>> > There may be more information reported by the environment (see
> above).
> >>> >
> >>> > This may be because the daemon was unable to find all the needed
> >>> > shared
> >>> > libraries on the remote node. You may set your LD_LIBRARY_PATH to
> >>> > have the
> >>> > location of the shared libraries on the remote nodes and this will
> >>> > automatically be forwarded to the remote nodes.
> >>> >
> >>>
> >>>
> --------------------------------------------------------------------------
> >>> >
> >>>
> >>>
> --------------------------------------------------------------------------
> >>> > mpirun noticed that the job aborted, but has no info as to the
> process
> >>> > that caused that situation.
> >>> >
> >>>
> >>>
> --------------------------------------------------------------------------
> >>> > mpirun: clean termination accomplished
> >>> >
> >>> > erin_at_erin-laptop:~$
> >>> >
> >>> > Any help would be much appreciated.
> >>> >
> >>> > Sincerely,
> >>> > Erin
> >>> >
> >>> >
> >>> > Erin M. Hodgess, PhD
> >>> > Associate Professor
> >>> > Department of Computer and Mathematical Sciences
> >>> > University of Houston - Downtown
> >>> > mailto: hodgesse_at_[hidden]
> >>> >
> >>> >
> >>> > _______________________________________________
> >>> > users mailing list
> >>> > users_at_[hidden]
> >>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>>
> >>>
> >>>
> >>>
> >>> _______________________________________________
> >>> users mailing list
> >>> users_at_[hidden]
> >>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>>
> >>
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >>
> >>
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
>
> Can you type us the follow output?
>
> > echo $LD_LIBRARY_PATH
>
> If this command doesn´t produce any output, you must define the
> environment variable:
>
> export LD_LIBRARY_PATH=/usr/lib/openmpi/lib/
>
> (export LD_LIBRARY_PATH=/usr/lib64/openmpi/lib/ if you have 64 bit
> distribution)
>
> Saludos,
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users