Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Question on open-mpi not working over wireless between Ubuntu and Mac OS-X
From: Pallab Datta (datta_at_[hidden])
Date: 2009-09-18 21:01:27


Hi,

Any help on how to debug this further..!? What options can i provide at
the command prompt.
--pallab

> Hello Pallab,
>
> Is there a chance its something simple like having the Mac's
> Fireware turned on? On my 10.4 system this is in System Preference-
> >Sharing, and then the Firewall tab.
>
> -Joshua Bernstein
> Senior Software Engineer
> Penguin Computing
>
> On Sep 18, 2009, at 3:56 PM, Pallab Datta wrote:
>
>> Hello,
>>
>> I am running open-mpi between a Mac OSX (v.10.5) and Ubuntu Server
>> V.9.04
>> (Linux Box). I have configured OMPI V.1.3.3 on both of them with
>> --enable-heterogeneous --disable-shared --enable-static options.
>> The Linux
>> box is connected via a wireless USB Adapter to the same sub-network in
>> which the Macinstosh is sitting.
>>
>> When I tried to run mpirun with the following options between the
>> Linux
>> box with the wireless card with another linux machine on the network
>> everything works fine.
>> I ran :
>> /usr/local/bin/mpirun --mca OMPI_mca_mpi_preconnect_all 1 -np 2 -H
>> localhost,10.11.14.205 ./app
>>
>> and it works.
>>
>> When I tried to run mpirun with the -hetero option from the
>> Macintosh it
>> invokes the processes on both ends and then hangs at the MPI_Send
>> MPI_Receive functions.
>> I ran:
>>
>> /usr/local/bin/mpirun --mca btl_base_verbose 30 --mca
>> OMPI_mca_mpi_preconnect_all 1 -np 2 -hetero -H localhost,10.11.14.205
>> ./app
>>
>> and it hangs. I saw that the linux box is trying to connect() the Mac
>> using port 4/260. So I purposely forced mpi to look for higher
>> numbered
>> ports..
>>
>> I ran :
>> /usr/local/bin/mpirun --mca btl_tcp_port_min_v4 36900 -mca
>> btl_tcp_port_range_v4 32 --mca btl_base_verbose 30 --mca
>> OMPI_mca_mpi_preconnect_all 1 -np 2 -hetero -H localhost,10.11.14.205
>> ./app
>>
>> and it still hangs giving the following message:
>> btl: tcp: attempting to connect() to address 10.11.14.203 on port 9360
>>
>> 10.11.14.203 == localhost.
>>
>> Can anybody explain what I am missing and how I can make the
>> macintosh and
>> Linux boxes talk to each other over wireless..
>> regards,
>> pallab
>>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>