Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] unable to access or execute
From: Dominik Táborský (bremby_at_[hidden])
Date: 2009-09-15 05:36:46


So I have to manually copy the compiled hello world program to all of
the nodes so that they can be executed? I really didn't expect that...

So, where (in the filesystem) does the executable have to be? On the
same place as on the master?

Thanks

Dominik

Ralph Castain píše v Út 15. 09. 2009 v 02:27 +0200:
> I assume this
> executable doesn't have to be on the node - that would be
> silly
>
> Not silly at all - we don't preposition the binary for you. It has to
> be present on the node where it is to be executed.
>
> I have added an option to preposition binaries in the OMPI developer's
> trunk, but that feature isn't scheduled for release until the next
> major code release.
>
> 2009/9/14 Dominik Táborský <bremby_at_[hidden]>
> Hi again,
>
> Since last time I made progress - I compiled openMPI 1.3.3
> from sources,
> now I'm trying to run it on one of my nodes. I am using the
> same
> software on the master, but master is Ubuntu 9.04 (NOT using
> openMPI
> 1.3.2 from repos) and the node is my own Linux system - it
> lacks many
> features so there might be the source of the problem.
>
> When I try to run hello world program, it gives me this error:
>
> $ /openMPI/bin/mpirun
> -hostfile /home/eddy/Dreddux/host.machine5 ./projekty/openMPI/hello/hello
> --------------------------------------------------------------------------
> mpirun was unable to launch the specified application as it
> could not
> access
> or execute an executable:
>
> Executable: ./projekty/openMPI/hello/hello
> Node: machine5
>
> while attempting to start process rank 0.
> --------------------------------------------------------------------------
>
> The executable is hello world program and is executable. I
> assume this
> executable doesn't have to be on the node - that would be
> silly. So, I
> don't understand what am I missing. Any ideas? Please!
>
> Dominik
>
> PS: thanks for your time!
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users