Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Mac OSX 10.6 (SL) + openMPI 1.3.3 + Intel Compilers 11.1.058 => Segmentation fault
From: Marcus Herrmann (marcus.herrmann_at_[hidden])
Date: 2009-09-08 10:10:50


Christophe,
the 11.1.058 compilers are not (yet) compatible with snow leopard. See
the Intel compiler Forums. The gnu compilers however work.

Marcus

On Sep 8, 2009, at 1:42 AM, Christophe Peyret <christophe.peyret_at_[hidden]
> wrote:

> Hello,
>
> After installing Snow Leopard, I rebulit openMPI 1.3.3 and wrap
> intel Compilers v 11.1.058. To do this, I used that small shell
> script :
>
> #! /bin/bash
> ./configure --prefix=/usr/local/openmpi-1.3.3-
> i64 \
> CFLAGS="-arch x86_64" CXXFLAGS="-arch x86_64" FCFLAGS="-m64" \
> F77=/opt/intel/Compiler/11.1/058/bin/intel64/
> ifort \
> FC=/opt/intel/Compiler/11.1/058/bin/intel64/ifort \
> CC=/opt/intel/Compiler/11.1/058/bin/intel64/icc \
> CXX=/opt/intel/Compiler/11.1/058/bin/intel64/icpc
>
> make
> make install
>
>
> This seems to work but, when I try to use openMPI, I have a
> Segmentation Fault
>
> mpic++ -showme -> Segmentation fault
> mpif90 -showme -> Segmentation fault
> ompi_info -> Segmentation fault
> ...
>
>
> Remark :
>
> I don't beleive it is a problem with dynamic library, as you can see
> my DYLD_LIBRARY_PATH path seems to be weel defined :
>
> echo $DYLD_LIBRARY_PATH
> :/opt/intel/Compiler/11.1/058/lib/:/opt/intel/Compiler/11.1/058/lib/
> intel64/:/opt/intel/Compiler/11.1/058/Frameworks/mkl/lib/em64t:/usr/
> local/openmpi-1.3.3-i64/lib:/usr/local/vtk-5.4.2/lib/vtk-5.4
>
>
> @+
> Christophe Peyret
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users