Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Help: orted: command not found.
From: Tomislav Maric (tomislav.maric_at_[hidden])
Date: 2009-08-24 03:37:27


Lee Amy wrote:
> Hi,
>
> I run some programs by using OpenMPI 1.3.3 and when I execute the
> command I encountered such following error messages.
>
> sh: orted: command not found
> --------------------------------------------------------------------------
> A daemon (pid 6797) died unexpectedly with status 127 while attempting
> to launch so we are aborting.
>
> There may be more information reported by the environment (see above).
>
> This may be because the daemon was unable to find all the needed shared
> libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
> location of the shared libraries on the remote nodes and this will
> automatically be forwarded to the remote nodes.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun noticed that the job aborted, but has no info as to the process
> that caused that situation.
> --------------------------------------------------------------------------
> mpirun: clean termination accomplished
>
> So could anyone tell me how to fix that problem?
>
> Thanks.
>
> Amy
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

The mpirun cannot be executed on the remote host because the bin and lib
directory for OMPI haven't been added to the PATH and LD_LIBRARY_PATH.

Try executing mpirun with the full pathname:

/path/to/mpirun -np 2 ...

Besides that, mpirun executes shell commands in non-interactive login
mode (man sh, or man bash), and since I'm using bash, I have to edit
.bashrc file on the remote host and add OMPI's bin and lib directories
to PATH and LD_LIBRARY_PATH. There should be similar file for setting
the enviroment for non-interactive login mode of the sh shell.

I have been using LiveCD SLAX linux, so my environmental variables were
exactly the same on both hosts, that allowed me to copy the output of
the "printenv" command on the master into .ssh/environment file on the
remote node. Did you install OMPI in the same places on both machines as
suggested on the web site?

Good luck!

Tomislav