Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] tcp connectivity OS X and 1.3.3
From: Jody Klymak (jklymak_at_[hidden])
Date: 2009-08-14 13:15:08


Hi All,

Just to polish this thread off....

To make openmpi work on my OS X 10.5 machine I need only:

./configure --prefix=/Network/Xgrid/openmpi
make
make install

I then edited
/Network/Xgrid/openmpi/etc/openmpi-mca-params.conf
and added

# set ports so that they are more valid than the default ones (see
email from Ralph Castain)
btl_tcp_port_min_v4 = 36900
btl_tcp_port_range = 32

Which may be a kludge only I need because I am being silly and running
openMPI as an admin-privileged user.

For my environment, I don't *need* to set anything, though I find it
useful to set:

export PATH="/Network/Xgrid/openmpi/bin/:$PATH:/usr/local/bin:/usr/
local/sbin"
export MANPATH="/Network/Xgrid/openmpi/man/:/usr/local/man/:$MANPATH"

Note that I do not think I need to set LD_LIBRARY_PATH (which I don't
think OS X knows anything about anyway) nor DYLD_LIBRARY_PATH. This
is consistent with the FAQ that warns against setting those (though
when I had them set there didn't seem to be any ill effects).

I'm running a long job now under torque/pbs. I'll see if it survives
the weekend (I had trouble with XGrid jobs dying after 10 hours or so
due to an sshd deciding it was a security breach and killing all the
processes).

Anyways, all seems to be working so far. Sorry that my poor choice in
user management caused so many mysteries. Thanks for everyone's help.

Cheers, Jody

--
Jody Klymak
http://web.uvic.ca/~jklymak/