Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problem configuring with torque
From: Gus Correa (gus_at_[hidden])
Date: 2009-08-11 11:57:13


Hi Craig, list

On my Rocks 4.3 cluster Torque is installed on /opt/torque,
not on /share/apps/torque.

That directory path may have changed on more recent versions of Rocks,
or you may have installed another copy of
of Torque on /share/apps/torque.
However, have you checked where Torque is installed?

My $0.02

Gus Correa

Ralph Castain wrote:
>
> On Aug 10, 2009, at 10:36 PM, Craig Plaisance wrote:
>
>> I am building openmpi on a cluster running rocks. When I build using
>> ./configure --with-tm=/share/apps/torque
>> --prefix=/share/apps/openmpi/intel I receive the warning
>> configure: WARNING: Unrecognized options: --with-tm,
>> --enable-ltdl-convenience
>
> You can ignore these - there are some secondary operations going on that
> don't understand the options used in the general build.
>
>> After running make and make install, I run ompi-info | grep tm and
>> don't see the entries
>>
>> MCA pls: tm (MCA v1.0, API v1.0, Component v1.0)
>> MCA ras: tm (MCA v1.0, API v1.0, Component v1.0)
>
> I assume you are building a 1.3.x version? If so, the pls framework no
> longer exists, which is why you don't see it. You should see a plm tm
> module, though.
>
> If you aren't seeing a ras tm module, then it is likely that the system
> didn't find the required Torque support. Are you sure the given path is
> correct?
>
> Note that the ras interface version has been bumped up, so it wouldn't
> show MCA v1.0 etc. - the numbers should be different now.
>
>
>>
>> Any idea what is happening? Thanks!
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users