Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] pipes system limit
From: Yann JOBIC (jobic_at_[hidden])
Date: 2009-08-07 11:53:30


Rolf Vandevaart wrote:
> This message is telling you that you have run out of file descriptors.
> I am surprised that the -mca parameter setting did not fix the problem.
> Can you run limit or ulimit on your shell and send the information? I
> typically set my limit to 65536 assuming the system allows it.
>
> burl-16 58 =>limit descriptors
> descriptors 65536
> burl-16 59 =>
>
> bash-3.00$ ulimit -n
> 65536
> bash-3.00$
>
>
> Rolf
Thanks for the fast answer !

I've done : limit descriptors 1024 (csh style)
And that's working fine. I took the linux descriptors by default.

Thanks again,

Yann

>
> On 08/07/09 11:21, Yann JOBIC wrote:
>> Hello all,
>>
>> I'm using hpc8.2 :
>> Lidia-jobic% ompi_info
>> Displaying Open MPI information for 32-bit ...
>> Package: ClusterTools 8.2
>> Open MPI: 1.3.3r21324-ct8.2-b09j-r40
>> [...]
>>
>> And i've got a X4600 machine (8*4 cores).
>>
>> When i'm trying to run a 32 processor jobs, i've got :
>>
>> Lidia-jobic% mpiexec --mca opal_set_max_sys_limits 1 -n 32 ./exe
>> [Lidia:29384] [[61597,0],0] ORTE_ERROR_LOG: The system limit on
>> number of pipes a process can open was reached in file
>> base/iof_base_setup.c at line 112
>> [Lidia:29384] [[61597,0],0] ORTE_ERROR_LOG: The system limit on
>> number of pipes a process can open was reached in file
>> odls_default_module.c at line 203
>> [Lidia:29384] [[61597,0],0] ORTE_ERROR_LOG: The system limit on
>> number of network connections a process can open was reached in file
>> oob_tcp.c at line 446
>> --------------------------------------------------------------------------
>>
>> Error: system limit exceeded on number of network connections that
>> can be open
>>
>> This can be resolved by setting the mca parameter
>> opal_set_max_sys_limits to 1,
>> increasing your limit descriptor setting (using limit or ulimit
>> commands),
>> or asking the system administrator to increase the system limit.
>> --------------------------------------------------------------------------
>>
>>
>> I tried the ulimit, the mca parameter, i've got no idea of where to
>> look at.
>> I've got the same computer under linux, and it's working fine...
>>
>> Have you seen it ?
>> Do you know a way to bypass it ?
>>
>> Many thanks,
>>
>> Yann
>>
>>
>
>

-- 
___________________________
Yann JOBIC
HPC engineer
Polytech Marseille DME
IUSTI-CNRS UMR 6595
Technopôle de Château Gombert
5 rue Enrico Fermi
13453 Marseille cedex 13
Tel : (33) 4 91 10 69 39
  ou  (33) 4 91 10 69 43
Fax : (33) 4 91 10 69 69