Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI and env. variables (LD_LIBRARY_PATH and PATH) - complete and utter Open MPI / Linux noob
From: Tomislav Maric (tomislav.maric_at_[hidden])
Date: 2009-08-02 14:18:38


Dominik Táborský wrote:
> Okay, now it's getting more confusing since I just found out that it
> somehow stopped working for me!
>
> Anyway, let's find a solution.
> I found out that there is difference between
> ssh node1 echo $PATH
> and
> ssh node1 'echo $PATH'
> These command give you different output. 'man ssh' states that it sets
> its own PATH variable right before the user logs in but after the
> connection is established. This variable is set during compilation.
>
> I am using dropbear as SSH2 server so I won't be able to guide you if
> you're using OpenSSH as a server, but the manpages should be sufficient.
> Look into man ssh and man ssh_config. You should create files ~/.ssh/rc
> OR ~/.ssh/config OR ~/.ssh/environment. Setting it up in one of these
> files should be enough.
>
> I will probably recompile dropbear with new default PATH.
>
> Anyway, I am sure it used to work for me and I have no idea why it
> stopped.
>
> If you'd need more help, just ask :-)
>
> Dr. Eddy
>

Thank you very much!! I'm also finding out about those files and I'm
using OpenSSH. I'll try and configure it to work. The weirdest thing is
that people who use Ubuntu on OpenFOAM forum just had to comment a line
in .bashrc that returns if the bash is run in non-interactive mode.

I just don't get it. Let me ask you just one thing, before the next 5-6
hours of fighting with config files:

what about NFS?

What if I export the directory? On OMPI pages is written that nfs
simplifies things. I'm noob in networking so I don't know if this would
benefit me.

If I edit ~/.ssh/environment then I have to manually set VARIABLE=VALUE,
and there are dozens of variables to set. I think I'll try the rc file
first.

Thank you again!

Best regards,
Tomislav