Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] bulding rpm
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-07-09 07:34:49


On Jul 7, 2009, at 1:32 AM, rahmani wrote:

> it create openmpi-1.3.2-1.x86_64.rpm with no error, but when I
> install it with rpm -ivh I see:
> error: Failed dependencies:
> libifcoremt.so.5()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libifport.so.5()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libimf.so()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libintlc.so.5()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libiomp5.so()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libsvml.so()(64bit) is needed by openmpi-1.3.2-1.x86_64
> libtorque.so.2()(64bit) is needed by openmpi-1.3.2-1.x86_64
> but all above library are in my computer
>

Several of these look like they are the intel compiler libraries. I
think that libtorque is the Torque support library (resource manager)
-- which seems weird because you explicitly built with SGE support.

Where are these library files located -- can they all be found via
your LD_LIBRARY_PATH?

> I use rpm -ivh --nodeps and it install completely, but when I use
> mpif90 and mpirun I see:
> $ /usr/local/openmpi/intel/1.3.2/bin/mpif90
> gfortran: no input files (I compile with ifort!!!!)
>

What does "/usr/local/openmpi/intel/1.3.2/bin/mpif90 --showme" show?

Does your LD_LIBRARY_PATH include a directory where another Open MPI
is installed? E.g., could running mpif90 be picking up the "wrong"
MPI installation? (and therefore picking up the other OMPI's compiler
preference -- gfortran in this case)

> $ /usr/local/openmpi/intel/1.3.2/bin/mpirun
> usr/local/openmpi/intel/1.3.2/bin/mpirun: symbol lookup error: /usr/
> local/openmpi/intel/1.3.2/bin/mpirun: undefined symbol: orted_cmd_line
>

mpirun didn't complain that it couldn't find its supporting .so
libraries, so I'm guessing LD_LIBRARY_PATH is pointing to *some* OMPI
libraries, but the fact that it can't find a symbol that it wants
leads me to believe that it's pointing to the "wrong" OMPI install.
What does "ldd /usr/local/openmpi/intel/1.3.2/bin/mpirun" show?

-- 
Jeff Squyres
Cisco Systems