Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI:Problem with 64-bit openMPI andintel compiler
From: Sims, James S. Dr. (james.sims_at_[hidden])
Date: 2009-07-25 00:21:08


thanks to all the responses. I've checked and I am using the proper 64-bit libs on all nodes. I'll
try upgrading to 1.3.3

Jim

________________________________________
From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] On Behalf Of Ralph Castain [rhc_at_[hidden]]
Sent: Friday, July 24, 2009 7:27 AM
To: Open MPI Users
Subject: Re: [OMPI users] Open MPI:Problem with 64-bit openMPI andintel compiler

Good point.

Other thing you might consider (though it is unlikely to be part of
this problem) is upgrading to 1.3.3. It probably isn't a good idea to
be using a release candidate for anything serious.

On Jul 24, 2009, at 5:21 AM, Jeff Squyres wrote:

> On Jul 23, 2009, at 11:14 PM, Ralph Castain wrote:
>
>> 3. get a multi-node allocation and run "pbsdsh echo $LD_LIBRARY_PATH"
>> and see what libs you are defaulting to on the other nodes.
>>
>
>
> Be careful with this one; you want to ensure that your local shell
> doesn't expand $LD_LIBRARY_PATH and simply display the same value on
> all nodes. It might be easiest to write a 2 line script and run that:
>
> $ cat myscript
> #!/bin/sh
> echo LD_LIB_PATH on `hostname` is: $LD_LIBRARY_PATH
> $ chmod +x myscript
> $ pdsh myscript
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users