Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MX questions
From: George Bosilca (bosilca_at_[hidden])
Date: 2009-06-25 17:34:45


On Jun 25, 2009, at 13:17 , Scott Atchley wrote:

> On Jun 25, 2009, at 1:02 PM, Dave Love wrote:
>
>> Also, Brice Goglin, the Open-MX author had a couple of questions
>> concerning multi-rail MX while I'm on:
>>
>> 1. Does the MX MTL work with multi-rail?
>
> I believe the answer is yes as long as all NICs are in the same
> fabric (they usually are).

If the multi-rail is enabled in the MX library then the MTL will use
it. Same for the BTL.

>
>> 2. "You may also want to ask why the MX BTL seems to be opening and
>> closing an additional endpoint during initialization. It seems to
>> make endpoint numbers a bit unpredictable here (causing my jobs to
>> use the wrong rail"
>>
>> Thanks for any info.
>
> Without knowing the code and/or looking, I believe OMPI opens an
> endpoint to get some mapping info (to see if the NIC is in the same
> fabric).

It is not the BTL who open the second endpoint, it is the MTL. It's a
very long story, but unfortunately right now the two components (MTL
and BTL) each open an endpoint. Once the upper level complete the
selection of the component for the run, one of the endpoints will be
closed.

   george.

>
> Scott
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users