Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] Problem with GNU GFortran OpenMPI 1.3.0
From: Si Hammond (simon.hammond_at_[hidden])
Date: 2009-06-22 16:14:04


Hi everyone,

Another little mystery for you all!

I have a relatively small MPI Fortran code which I can compile
successfully with Intel and PGI compiled OpenMPI 1.3.0 (and 1.2.5). No
problems with this.

On a separate machine I have a GNU Gfortran 4.3 OpenMPI 1.3.0
installation and I get these errors immediately after the code starts
running:

*** An error occurred in MPI_Comm_f2c
*** before MPI was initialized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[***:19386] Abort before MPI_INIT completed successfully; not able to
guarantee that all other processes were killed!
*** An error occurred in MPI_Comm_f2c
*** before MPI was initialized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
[***:13269] Abort before MPI_INIT completed successfully; not able to
guarantee that all other processes were killed!
*** An error occurred in MPI_Comm_f2c
*** before MPI was initialized
*** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
<etc>

So, it looks like there might be a bug with GFortran or do you think
this is OpenMPI?

Any help you have would be appreciated, I can't seem to find much on
this using Google.

Si Hammond

Performance Modelling, Analysis and Optimisation Team
High Performance Systems Group
Department of Computer Science
University of Warwick, CV4 7AL, UK