Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Error in mx_init (error MX library incompatible with driver version)
From: SLIM H.A. (h.a.slim_at_[hidden])
Date: 2009-06-19 13:05:51


This is a question I raised before but for OpenMPI over IB.

I have build the app with the Portland compiler and OpenMPI 1.2.3 for
Myrinet and InfiniBand. Now I wish to run this on some nodes that have
no fast interconnect. We use GridEngine, this is the script:

#!/bin/csh
#$ -cwd
##$ -j y

module purge
module load dot sge openmpi/pgi/64/1.2.3

echo "Got slots"

mpirun -np $NSLOTS --mca btl "sm,self,tcp" ./t2eco2n_mp

This gives the following error message:

[node168:30330] Error in mx_init (error MX library incompatible with
driver version)
MX:driver-api-seq-num differ (lib=5.1,kernel=2.1)
        MX Lib Version=1.2.5
        MX Lib Build=dcl0hpc_at_hamilton:/tmp/dcl0hpc/myrinet/mx-1.2.5 Wed
Apr 16 10:48:48 BST 2008
        MX Kernel Version=1.1.6
        MX Kernel Build=root_at_node014:/tmp/mx-1.1.6 Fri Nov 24 13:41:44
GMT 2006
[node168:30331] Error in mx_init (error MX library incompatible with
driver version)
[node168:30330] *** Process received signal ***
[node168:30330] Signal: Segmentation fault (11)
[node168:30330] Signal code: (128)
[node168:30330] Failing at address: (nil)
[node168:30330] *** End of error message ***

Although the mismatch between MX lib version and the kernel version
appears to cause the mx_init error this should never be called as there
is no mx card on those nodes.

Thanks in advance for any advice to solve this

Henk

Dr. H.A. Slim
IT Consultant, Scientific and High Performance Computing
IT Service,
Durham University, UK
e-mail: h.a.slim_at_[hidden]
Tel.: 0191 - 334 2724
FAX: 0191 - 3342701