Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_Lookup_name
From: jobic (jobic_at_[hidden])
Date: 2009-06-09 12:29:06


Ralph Castain a écrit :
> It works fine, but you didn't specify the ompi-server uri correctly.
> On the mpirun cmd line, you needed to specify it as "file:test" so we
> know that it is a filename and not something else. Here is the mpirun
> help output:
>
> "Specify the URI of the Open MPI server, or the name of the file
> (specified as file:filename) that contains that info"
>
> As given below, we attempted to use a uri of "test", which provides a
> meaningless contact point. I'll try to provide a more informative
> error message, though, as the current one is rather useless, I must
> admit. :-/
>
> Thanks
> Ralph
That's working fine !
Thanks for the fast answer.
Yann

>
>
> On Tue, Jun 9, 2009 at 9:58 AM, Yann JOBIC <jobic_at_[hidden]
> <mailto:jobic_at_[hidden]>> wrote:
>
> Hi all,
>
> I'm trying to get MPI_Lookup_name working.
> The codes are working fine with mpich2.
> I'm using ompi-1.3.2 (r21054, from the tar version)
>
> Here's the error message :
> [homard:26336] *** An error occurred in MPI_Lookup_name
> [homard:26336] *** on communicator MPI_COMM_WORLD
> [homard:26336] *** MPI_ERR_NAME: invalid name argument
> [homard:26336] *** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
>
> The method i used :
> TERM1 : ompi-server -d --report-uri test
> TERM2 : mpirun -ompi-server test -np 1 server
> TERM3 : mpirun -ompi-server test -np 1 client
> Then i've got the error.
>
> Here's the codes :
> http://www.latp.univ-mrs.fr/~jobic/server.c
> <http://www.latp.univ-mrs.fr/%7Ejobic/server.c>
> http://www.latp.univ-mrs.fr/~jobic/client.c
> <http://www.latp.univ-mrs.fr/%7Ejobic/client.c>
>
> I also have some strange errors, like :
> [homard:26319] [[34061,0],0] ORTE_ERROR_LOG: Bad parameter in file
> base/rml_base_contact.c at line 153
> [homard:26319] [[34061,0],0] ORTE_ERROR_LOG: Bad parameter in file
> rml_oob_contact.c at line 55
> [homard:26319] [[34061,0],0] ORTE_ERROR_LOG: Bad parameter in file
> base/rml_base_contact.c at line 91
>
> Have you succeed in making MPI_Lookup_name work ??
>
> Thanks,
>
> Yann
>