Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] How to use Multiple linkswithOpenMPI??????????????????
From: shan axida (axida2009_at_[hidden])
Date: 2009-06-08 02:04:23


Hi,
Yes, we 2 NICs on the same bus and the other 2 are embeded.
We did the experiment about netperf in our cluster and we
could not get full bandwith using 4 pairs copies on two nodes.
the bandwidth is increased when the number of NICs changes to 2
but there is no big increase when it becomes 3, 4.

Thank you!
Axida.

________________________________
From: Jeff Squyres <jsquyres_at_[hidden]>
To: Open MPI Users <users_at_[hidden]>
Sent: Friday, June 5, 2009 11:19:02 PM
Subject: Re: [OMPI users] How to use Multiple linkswithOpenMPI??????????????????

On Jun 4, 2009, at 3:42 AM, shan axida wrote:

> We have Dell powerconnect 2724 Gigabit switches to connect the nodes in our cluster.
> As you said, may be the speed of PCI bus is a bottleneck.
> How can check it in practical?

Are all your gige nics on the same bus?

You might want to try running multiple copies of TCP pt2pt benchmarks simultaneously on your machine to see what kind of performance you get. E.g., run 4 copies of netperf on node A talking to 4 corresponding copies of netper on node B. Do you get full bandwidth out of all 4 copies?

--Jeff Squyres
Cisco Systems

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users