Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] What flags for configure for a single machine installation ?
From: DEVEL Michel (Michel.Devel_at_[hidden])
Date: 2009-06-05 08:36:59


Terry Frankcombe a écrit :
> Is there any compelling reason you're not using the wrappers
> mpif77/mpif90?
>
>
In fact, this is for the same reason that I also try to use static linking:
I have been using two middle-size clusters as a normal user without root
privilege.
Hence I cannot update the compiler/libraries... packages.
The binaries are installed via apt-get (Debian distro) and almost never
updated by the administrator.
Hence, they are not optimized for our hardware.
The default gfortran is still 4.1.2 and ifort is 10.0 20070426 (hence
also mpif90).
I have made tests with more recent compilers and libraries installed
under my account and the system compilers indeed produce much slower codes.
I could go on this way and use LD_LIBRARY_PATH to point to my private
versions of the compilers/library but I have problems with the fact that
the SGE batch system uses an openmpi environment with an old version of
openmpi coherent with the compilers and glibc versions...
Furthermore, I would like to have the same computing environment on my
machine and on the cluster.

Maybe there is a clever way to deal with my problems than going for
static link, but I have already wasted quite some time trying other
solutions unsuccessfully. However, I would evidently appreciate if
someone could point me one! ;-)

-- 
Sincerely yours,
Michel DEVEL