Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Pb in configure script when using ifort with "-fast" + link of opal_wrapper
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-06-04 21:02:45


On Jun 3, 2009, at 1:07 PM, DEVEL Michel wrote:

> I did not check your mails before because I was busy trying the gcc/
> gfortran way.
> I have other problems:
> - for static linking I am missing plenty of ibv_* routines. I saw on
> the net that they should be in a libibverbs library, but I cannot
> find it.

Static linking for the verbs library is not for the faint of heart.
See the OMPI FAQ in the Open Fabrics section if you really want to
statically link; there's a question about exactly this issue.

> - dynamic linking is OK, but when I test a simple test program on my
> machine (i7 920) with an mpd-hosts containing a single line with the
> name of the machine and slots=4, the program only execute provided I
> give my password, allthough I do have a .rhosts file with the name
> of my machine in my home directory.
>
Note that we're still working on the static linking with the intel
compiler issue; it's more complex than we initially thought.

Also note that this issue you're having is likely to happen with for
static and shared linking -- it's probably your ssh setup, not
anything to do with static or shared linking. Can you ssh to the
remote machine without entering a password? That's what you need to
have working.

-- 
Jeff Squyres
Cisco Systems