Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] What flags for configure for a single machine installation ?
From: Terry Frankcombe (terry_at_[hidden])
Date: 2009-06-04 20:17:49


Is there any compelling reason you're not using the wrappers
mpif77/mpif90?

On Thu, 2009-06-04 at 18:01 +0200, DEVEL Michel wrote:
> Dear all,
>
> I still have problems with installing and using openmpi:
>
> 1°) In fact I just want to install openmpi on my machine (single i7 920)
> to be able to develop parallel codes (using eclipse/photran/PTP) that I
> will execute on a cluster later (using SGE batch queue system).
> I therefore wonder what kind of configure flags I could put to have a
> basic single-machine installation ?
>
> 2°) For GCC, "./configure --prefix=/usr/local --with-sge
> --enable-static" worked but when I try to statically link a test code by
> gfortran -m64 -O3 -fPIC -fopenmp -fbounds-check -pthread --static
> testmpirun.f -o bin/testmpirun_gfortran_static -I/usr/local/include
> -L/usr/local/lib -lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl
> -lnsl -lutil -lm -ldl
> It fails because the link step does not find Infiniband routines (ibv_*).
> If I use dynamical link, it works but asks me for a password when I try
> to do
> "/usr/bin/local/mpirun -np 4 bin/testmpirun_gfortran_static" though I
> have an a priori valid .rhosts file...
>
> 3°) for the intel compiler suite case
> "./configure --prefix=/opt/intel/Compiler/11.0/074 --with-sge
> --enable-static CC='icc' CFLAGS=' -xHOST -ip -O3 -C' LDFLAGS='-xHOST -ip
> -O3 -C -static-intel' AR='ar' F77='ifort' FC='ifort' FFLAGS=' -xHOST -ip
> -O3 -C' FCFLAGS=' -xHOST -ip -O3 -C' CXX='icpc' CXXFLAGS=' -xHOST -ip
> -O3 -C'"
> worked but I have the same problem with missing ibv_ * routines if I try
> a static link
> "ifort -Bdynamic -fast -C -openmp -check noarg_temp_created
> testmpirun.f -o bin/testmpirun_ifort_dynamic
> -I/opt/intel/Compiler/11.0/074/include
> -L/opt/intel/Compiler/11.0/074/lib -lmpi_f90 -lmpi_f77 -lmpi -lopen-rte
> -lopen-pal -ldl -lnsl -lutil -lm -ldl"
>
> (Remark: If I add "-static" to LDFLAGS in configure, it stops during
> the making of opal_wrapper).
>
> If I use dynamic link, I get the executable but then
> /opt/intel/Compiler/11.0/074/bin/mpirun -np 4
> ../../bin/testmpirun_ifort_dynamic
> gives
> --------------------------------------------------------------------------
> mpirun noticed that process rank 0 with PID 16664 on node mn2s-devel
> exited on signal 11 (Segmentation fault).
> --------------------------------------------------------------------------
> 2 total processes killed (some possibly by mpirun during cleanup)
>
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users