Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_COMM_WORLD Error
From: mtcreekmore_at_[hidden]
Date: 2009-05-26 21:30:02


I finally got it.
Thanks

> From: jsquyres_at_[hidden]
> To: users_at_[hidden]
> Date: Tue, 26 May 2009 20:49:34 -0400
> Subject: Re: [OMPI users] MPI_COMM_WORLD Error
>
> Don't use the mpif.h from that site; Open MPI ships with its own.
> mpif90 will find it -- you don't need to copy it into the same
> directory as your .f sources.
>
>
> On May 26, 2009, at 8:21 PM, <mtcreekmore_at_[hidden]> wrote:
>
> > Thanks for your reply Eugene.
> >
> >
> >
> > Here is the result of the mpif90 -showme
> >
> >
> > /state/partition1/apps/intel/fce/10.1.015/bin/ifort -I/share/apps/
> > openmpi-1.2.6-intel/include -pthread -I/share/apps/openmpi-1.2.6-
> > intel/lib -L/usr/pbs/lib -L/share/apps/openmpi-1.2.6-intel/lib -
> > lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -lrt -lpbs -lnuma -
> > ldl -Wl,--export-dynamic -lnsl -lutil
> >
> >
> > The mpif.h file I got off the site. I used the Google "site:
> > mcs.anl.gov mpif.h" search and placed it into the same directory as
> > the main program.
> >
> > So if it is the correct one, I am not sure.
> >
> > Trent
> >
> >
> >
> > Date: Tue, 26 May 2009 16:54:02 -0700
> > From: Eugene.Loh_at_[hidden]
> > To: users_at_[hidden]
> > Subject: Re: [OMPI users] MPI_COMM_WORLD Error
> >
> > mtcreekmore_at_[hidden] wrote:
> >
> > I and new to OpenMPI and have looked for this, but not getting
> > anywhere.
> >
> > I got an example program off this site:
> >
> > The compute PI in Fortran example.
> > http://www.mcs.anl.gov/research/projects/mpi/usingmpi/examples/simplempi/main.htm
> >
> > Compiled it with "mpif90" and no errors.
> > Then used the qsub -I and tried both executing directly and "mpirun"
> > and still receive these errors:
> >
> > [MGT-2-1:02994] *** An error occurred in MPI_Comm_rank
> > [MGT-2-1:02994] *** on communicator MPI_COMM_WORLD
> > [MGT-2-1:02994] *** MPI_ERR_COMM: invalid communicator
> > [MGT-2-1:02994] *** MPI_ERRORS_ARE_FATAL (goodbye)
> >
> > Any guidance in the right direction would be appreciated.
> > First, the example works fine for me.
> >
> > You seem to be bombing in MPI_Comm_rank and before it asks you for
> > any input. I guess it's having problems with the MPI_COMM_WORLD
> > communicator being passed to MPI_Comm_rank? Maybe it's having
> > problems finding the mpif.h include file? It's finding *some*
> > mpif.h include file, but presumably not the right one. Make sure
> > the mpif90 and mpirun commands are the ones you think you should be
> > getting and, if they are, try adding -showme to the mpif90 line to
> > see where it's looking for the mpif.h include file.
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users