Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_COMM_WORLD Error
From: mtcreekmore_at_[hidden]
Date: 2009-05-26 20:01:04


Thanks for the reply Doug.
I was not responsible for the build. It was already setup on one of the university's computers.
I would have to ask the administrator about that.
Trent

From: dlr_at_[hidden]
To: users_at_[hidden]
Date: Tue, 26 May 2009 16:50:47 -0700
Subject: Re: [OMPI users] MPI_COMM_WORLD Error

Trent,
Did you build openmpi with support for torque, it isn't in the default configure.
Doug Reeder
On May 26, 2009, at 4:29 PM, <mtcreekmore_at_[hidden]> <mtcreekmore_at_[hidden]> wrote:I and new to OpenMPI and have looked for this, but not getting anywhere.

I got an example program off this site:
The compute PI in Fortran example.
http://www.mcs.anl.gov/research/projects/mpi/usingmpi/examples/simplempi/main.htm

Compiled it with "mpif90" and no errors.Then used the qsub -I and tried both executing directly and "mpirun" and still receive these errors:
[MGT-2-1:02994] *** An error occurred in MPI_Comm_rank[MGT-2-1:02994] *** on communicator MPI_COMM_WORLD[MGT-2-1:02994] *** MPI_ERR_COMM: invalid communicator[MGT-2-1:02994] *** MPI_ERRORS_ARE_FATAL (goodbye)
Any guidance in the right direction would be appreciated.
Thanks
Trent

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users