Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] scaling problem with openmpi
From: Pavel Shamis (Pasha) (pashash_at_[hidden])
Date: 2009-05-18 12:50:49


Roman,
Can you please share with us Mvapich numbers that you get . Also what is
mvapich version that you use.
Default mvapich and openmpi IB tuning is very similar, so it is strange
to see so big difference. Do you know what kind of collectives operation
is used in this specific application.

Pasha.

Roman Martonak wrote:
> I've been using --mca mpi_paffinity_alone 1 in all simulations. Concerning "-mca
> mpi_leave_pinned 1", I tried it with openmpi 1.2.X versions and it
> makes no difference.
>
> Best regards
>
> Roman
>
> On Mon, May 18, 2009 at 4:57 PM, Pavel Shamis (Pasha) <pashash_at_[hidden]> wrote:
>
>>> 1) I was told to add "-mca mpi_leave_pinned 0" to avoid problems with
>>> Infinband. This was with OpenMPI 1.3.1. Not
>>>
>> Actually for 1.2.X version I will recommend you to enable leave pinned "-mca
>> mpi_leave_pinned 1"
>>
>>> sure if the problems were fixed on 1.3.2, but I am hanging on to that
>>> setting just in case.
>>>
>> We had data corruption issue in 1.3.1 but it was resolved in 1.3.2. In 1.3.2
>> version leave_pinned is enabled by default.
>>
>> If I remember correct mvapich enables affinity mode by default, so I can
>> recommend you to try to enable it too:
>> "--mca mpi_paffinity_alone 1". For more details please check FAQ -
>> http://www.open-mpi.org/faq/?category=tuning#using-paffinity
>>
>> Thanks,
>> Pasha.
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>
>