Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] New warning messages in 1.3.2 (not present in1.2.8)
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-05-12 08:48:02


On May 12, 2009, at 8:17 AM, Matthieu Brucher wrote:

> OK, this is indeed the case. I'll try to clean the tree (I have
> several other package and deleted the original 1.2.8 package) and test
> again.
>

This misleading libltdl error message continues to bite us over and
over again (users and developers alike), so I just put in a workaround
with some heuristics to try to print a better error message in cases
like yours. Now you'll see something like this:

[foo.example.com:24273] mca: base: component_find: unable to open /
home/jsquyres/bogus/lib/openmpi/mca_btl_openib: perhaps a missing
symbol, or compiled for a different version of Open MPI? (ignored)

Changeset here (Shiqing tells me it'll work on Windows, too -- MTT
will tell us for sure :-) ):

     https://svn.open-mpi.org/trac/ompi/changeset/21214

And I filed to move it to v1.3.3 here:

     https://svn.open-mpi.org/trac/ompi/ticket/1917

-- 
Jeff Squyres
Cisco Systems