Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mpirun fails on remote applications
From: feng chen (fch6699_at_[hidden])
Date: 2009-05-12 01:18:24


hi all,

First of all,i'm new to openmpi. So i don't know much about mpi setting. That's why i'm following manual and FAQ suggestions from the beginning.
Everything went well untile i try to run a pllication on a remote node by using 'mpirun -np' command. It just hanging there without doing anything, no error messanges, no
complaining or whatsoever. What confused me is that i can run application over ssh with no problem, while it comes to mpirun, just stuck in there does nothing.
I'm pretty sure i got everyting setup in the right way manner, including no password signin over ssh, environment variables for bot interactive and non-interactive logons.
A sample list of commands been used list as following:

[fch6699_at_anfield05 test]$ mpicc -o hello hello.f
[fch6699_at_anfield05 test]$ ssh anfield04 ./hello
0 of 1: Hello world!
[fch6699_at_anfield05 test]$ mpirun -host anfield05 -np 4 ./hello
0 of 4: Hello world!
2 of 4: Hello world!
3 of 4: Hello world!
1 of 4: Hello world!
[fch6699_at_anfield05 test]$ mpirun -host anfield04 -np 4 ./hello
just hanging there for years!!!
need help to fix this !!
if u try it in another way
[fch6699_at_anfield05 test]$ mpirun -hostfile my_hostfile -np 4 ./hell
still nothing happened, no warnnings, no complains, no error messages.. !!

All other files related to this issue can be found in my_files.tar.gz in attachment.

.cshrc
The output of the "ompi_info --all" command.
my_hostfile
hello.c
output of iptables

The only thing i've noticed is that the port of our ssh has been changed from 22 to other number for security issues.
Don't know will that have anything to with it or not.

Any help will be highly appreciated!!

thanks in advance!

Kevin