Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with running openMPI program
From: Gus Correa (gus_at_[hidden])
Date: 2009-04-22 11:41:01


Hi

Do "yum list | grep mpi" to find the correct package names.
Then uninstall them with "yum remove" using the correct package name.

Don't use yum to install different flavors of MPI.
Things like mpicc, mpirun, MPI libraries, man pages, etc,
will get overwritten in /usr or /usr/local.
If you want to use yum, install only one MPI flavor.

OR (after removing the old packages with yum):

Reinstall OpenMPI from source.
Use the --prefix-/your/target/OpenMPI/dir during configure.

Reinstall MPICH2 from source.
Use the --prefix-/your/target/MPICH2/dir during configure.

Use different directories for OpenMPI and MPICH2.
Or install only one MPI flavor.

I hope this helps.

Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

Ankush Kaul wrote:
> i feel the above problem occured due 2 installing mpich package, now
> even nomal mpi programs are not running.
> What should we do? we even tried *yum remove mpich* but it says no
> packages to remove.
> Please Help!!!
>
> On Wed, Apr 22, 2009 at 11:34 AM, Ankush Kaul <ankush.rkaul_at_[hidden]
> <mailto:ankush.rkaul_at_[hidden]>> wrote:
>
> We are facing another problem, we were tryin to install different
> benchmarking packages
>
> now whenever we try to run *mpirun* command (which was working
> perfectly before) we get this error:
> /usr/local/bin/mpdroot: open failed for root's mpd conf filempdtrace
> (__init__ 1190): forked process failed; status=255/
>
> whats the problem here?
>
>
>
>
> On Tue, Apr 21, 2009 at 11:45 PM, Gus Correa <gus_at_[hidden]
> <mailto:gus_at_[hidden]>> wrote:
>
> Hi Ankush
>
> Ankush Kaul wrote:
>
> @Eugene
> they are ok but we wanted something better, which would more
> clearly show de diff in using a single pc and the cluster.
>
> @Prakash
> i had prob with running de programs as they were compiling
> using mpcc n not mpicc
>
> @gus
> we are tryin 2 figure out de hpl config, its quite complicated,
>
>
> I sent you some sketchy instructions to build HPL,
> on my last message to this thread.
> I built HPL and run it here yesterday that way.
> Did you try my suggestions?
> Where did you get stuck?
>
>
> also de locate command lists lots of confusing results.
>
>
> I would say the list is just long, not really confusing.
> You can find what you need if you want.
> Pipe the output of locate through "more", and search carefully.
> If you are talking about BLAS try "locate libblas.a" and
> "locate libgoto.a".
> Those are the libraries you need, and if they are not there
> you need to install one of them.
> Read my previous email for details.
> I hope it will help you get HPL working, if you are interested
> on HPL.
>
>
> I hope this helps.
>
> Gus Correa
> ---------------------------------------------------------------------
> Gustavo Correa
> Lamont-Doherty Earth Observatory - Columbia University
> Palisades, NY, 10964-8000 - USA
> ---------------------------------------------------------------------
>
> @jeff
> i think u are correct we may have installed openmpi without
> VT support, but is there anythin we can do now???
>
> One more thing I found this program but dont know how to run
> it : http://www.cis.udel.edu/~pollock/367/manual/node35.html
>
> Thanks 2 all u guys 4 putting in so much efforts to help us out.
>
>
> ------------------------------------------------------------------------
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden] <mailto:users_at_[hidden]>
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden] <mailto:users_at_[hidden]>
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users