Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with running openMPI program
From: Gus Correa (gus_at_[hidden])
Date: 2009-04-22 11:25:36


Hi Ankush

I second Eugene's comments.

I already sent you on previous emails to this thread
all relevant information on where to
get HPL from Netlib (http://netlib.org/benchmark/hpl/),
Goto BLAS from TACC (http://www.tacc.utexas.edu/resources/software/),
and the standard BLAS from Netlib (http://www.netlib.org/blas/).
OK, there go the links once again!

I also sent you instructions on how to install HPL,
exactly as I installed it here two days ago.
Did you read those instructions?
It is one of the messages on this thread.
Check the mailing list archive, if you don't have that email anymore.

Eugene just sent you a gotcha on how to build Netlib BLAS.
Goto BLAS is also easy to install with its "quickbuild" scripts,
and it comes with Readme, QuickInstall, and FAQ files, which you should
read.

However, somehow you are repeating the same questions
that I and others already answered.
There isn't much more I can say to help you out.

Good luck!

Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

Eugene Loh wrote:
> Ankush Kaul wrote:
>
>> @gus
>> we are not able to make hpl sucessfully.
>>
>> i think it has to do something with blas
>>
>> i cannot find blas tar file on the net, i found rpm but de
>> installation steps is with tar file.
>
> First of all, this mail list is for Open MPI issues. On this list are
> people who are helpful and know about lots of stuff (including things
> having anything at all to do with MPI), but HPL and HPCC have their own
> support mechanisms and you should probably pursue those for HPL questions.
>
> Anyhow, if I google "blas", I immediately come up with netlib.org, which
> is where you can get a BLAS source tar file. I've had to go through the
> HPL experience myself in the last 0-2 days, and it seems to me that the
> netlib.org site is not responding. So, one can google "netlib mirror"
> to find mirror sites, poke around a little, and end up getting BLAS from
> the Sandia mirror site.
>
> Short version: try http://netlib.sandia.gov/blas/blas.tgz
>
> I found a gotcha. I changed the "g77" in the BLAS/make.inc file to
> become mpif77. Also, in the HPL hpl/Make.$ARCH file, I used mpif77 for
> the linker. This way, some Fortran I/O routines used by blas (xerbla.f)
> will be found at link time. (I was using HPL from HPCC. Not sure if
> your HPL is the same.)
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users