Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libnuma issue
From: Nysal Jan (jnysal_at_[hidden])
Date: 2009-04-15 22:43:21


You could try statically linking the Intel-provided libraries. Use
LDFLAGS=-static-intel

--Nysal

On Wed, 2009-04-15 at 21:03 +0200, Francesco Pietra wrote:
> On Wed, Apr 15, 2009 at 8:39 PM, Prentice Bisbal <prentice_at_[hidden]> wrote:
> > Francesco Pietra wrote:
> >> I used --with-libnuma=/usr since Prentice Bisbal's suggestion and it
> >> worked. Unfortunately, I found no way to fix the failure in finding
> >> libimf.so when compiling openmpi-1.3.1 with intels, as you have seen
> >> in other e-mail from me. And gnu compilers (which work well with both
> >> openmpi and the slower code of my application) are defeated by the
> >> faster code of my application. With limited hardware resources, I must
> >> rely on that 40% speeding up.
> >>
> >
> > To fix the libimf.so problem you need to include the path to Intel's
> > libimf.so in your LD_LIBRARY_PATH environment variable. On my system, I
> > installed v11.074 of the Intel compilers in /usr/local/intel, so my
> > libimf.so file is located here:
> >
> > /usr/local/intel/Compiler/11.0/074/lib/intel64/libimf.so
> >
> > So I just add that to my LD_LIBRARY_PATH:
> >
> > LD_LIBRARY_PATH=/usr/local/intel/Compiler/11.0/074/lib/intel64:$LD_LIBRARY_PATH
> > export LD_LIBRARY_PATH
>
> Just a clarification: With my system I use the latest intels version
> 10, 10.1.2.024, and mkl 10.1.2.024 because it proved difficult to make
> a debian package with version 11. At
>
> echo $LD_LIBRARY_PATH
>
> /opt/intel/mkl/10.1.2.024/lib/em64t:/opt/intel/cce/10.1.022/lib:opt/intel/fce/10.1.022/lib:/usr/local/lib
>
> (that /lib contains libimf.so)
>
> That results from sourcing in my .bashrc:
>
> . /opt/intel/fce/10.1.022/bin/ifortvars.sh
> . /opt/intel/cce/10.1.022/bin/iccvars.sh
>
> Did you suppress that sourcing before exporting the LD_EXPORT_PATH to
> the library at issue? Having so much turned around the proble, it is
> not unlikely that I am messing myself.
>
> thanks
> francesco
>
>
> >
> > Now I can run whatever programs need libimf.so without any problems. In
> > your case, you'll want to that before your make command.
> >
> > Here's exactly what I use to compile OpenMPI with the Intel Compilers:
> >
> > export PATH=/usr/local/intel/Compiler/11.0/074/bin/intel64:$PATH
> >
> > export
> > LD_LIBRARY_PATH=/usr/local/intel/Compiler/11.0/074/lib/intel64:$LD_LIBRARY_PATH
> >
> > ../configure CC=icc CXX=icpc F77=ifort FC=ifort
> > --prefix=/usr/local/openmpi-1.2.8/intel-11/x86_64 --disable-ipv6
> > --with-sge --with-openib --enable-static
> >
> > --
> > Prentice
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users