Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] PGI Fortran pthread support
From: Gus Correa (gus_at_[hidden])
Date: 2009-04-14 13:09:03


Orion Poplawski wrote:
> Gus Correa wrote:
>> Hi Orion, Prentice, list
>>
>> I had a related problem recently,
>> building OpenMPI with gcc, g++ and pgf90 8.0-4 on CentOS 5.2.
>> Configure would complete, but not make.
>>
>
> Easier solution is to set FC to "pgf90 -noswitcherror". Does not appear
> to interfere with any configure tests.
>

Thank you, Orion!

That will also solve the problem,
and is certainly neater than stripping off the "-pthread" flag
with a fake compiler script.

I didn't know about "-noswitcherror", so many switches there are,
not all of them very clear, and the number is growing ...

The only problem I can think of would be if you misspell another switch,
one that you really want to use.
Man pgf90 says it will accept the misspell/mistake
with a warning message.
So, to be safe with "-noswitcherror",
one has to grep the make log for PGI warning messages, I suppose,
which is no big deal anyway.

Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------