Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so: undefined symbol: ls b_init
From: Chris Walker (christopher.walker_at_[hidden])
Date: 2009-04-11 23:04:30


We're having this same problem with 1.3 and 1.3.1. In our case, it
looks like mca_plm_lsf.so doesn't load libbat or liblsf:

[root_at_hero0101 openmpi]# ldd mca_plm_lsf.so
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00002adbec183000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00002adbec39b000)
        libm.so.6 => /lib64/libm.so.6 (0x00002adbec59e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002adbec822000)
        libc.so.6 => /lib64/libc.so.6 (0x00002adbeca3c000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003945c00000)
[root_at_hero0101 openmpi]#

mca_ess_lsf.so and mca_ras_lsf.so both do, however, e.g.,
[root_at_hero0101 openmpi]# ldd mca_ras_lsf.so
        libbat.so => /lsf/7.0/linux2.6-glibc2.3-x86_64/lib/libbat.so
(0x00002b86740ee000)
        liblsf.so => /lsf/7.0/linux2.6-glibc2.3-x86_64/lib/liblsf.so
(0x00002b8674384000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00002b8674693000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00002b86748ac000)
        libm.so.6 => /lib64/libm.so.6 (0x00002b8674aaf000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b8674d32000)
        libc.so.6 => /lib64/libc.so.6 (0x00002b8674f4d000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003945c00000)
[root_at_hero0101 openmpi]#

Chris